NH3H2O (Ammonia-Water) Properties

The NH3H2O procedure provides the thermodynamic properties of ammonia-water mixtures in subcooled, saturated and superheated conditions. The procedure is called from EES by the statement:

CALL NH3H2O(Code,In1,In2,In3: T,P,x,h,s,u,v,q)

The 4 parameters to the left of the colon are inputs to the procedure; the eight values to the right are outputs whose values are set by the NH3H2O procedure. The NH3H2O routine used the following properties which must be in the designated units.

T=[K]

P=[bar]

x=[ammonia mass fraction]

h=[kJ/kg]

s=[kJ/kg-K]

u=[kJ/kg],

v=[m3/kg]

q=[vapor mass fraction]

For saturated states, 0<=q<=1. Subcooled states are indicated with q=-0.001; superheated states have q=1.001.

Code is a 3 digit integer indicating which of the 8 possible properties are provided as input values. For example, a Code value of 123 indicates that the values of properties 1,2, and 3 are provided in inputs In1, In2, and In3, respectively. The property numbers correspond to their positions in the outputs. Properties 1,2, and 3 are thus temperature (T), pressure (P), and ammonia mass fraction(x).

Currently, NH3H2O supports Code values of 123, 128, 137, 138, 148, 158, 168, 178, 234, 235, 238, 248, 258, 268, and 278. However, one (or more) output values can be fixed and EES will determine the corresponding input values in an iterative solution. In this way, EES can determine the properties of ammonia-water given any three independent properties.

Example:

T=450 [K]

P=10 [bar]

x=0.5

CALL NH3H2O(123,T,P,x: T[1],P[1],x[1],h[1],s[1],u[1],v[1],q[1]) "123=> T,P,x"

After solving, the arrays window will display the following results:

The NH3H2O procedure is an example of an EES external procedure. This procedure has been separately compiled (in Fortran, C, Pascal, etc.) and copied into EES as a dynamically linked procedure .DLF file. The user may add any functions or procedures in this way, extending the capability of EES. See the manual for details.

The correlations in NH3H2O are from:

Ibrahim, O.M., Klein, S.A.,

"Thermodynamic Properties of Ammonia-Water Mixtures,"

ASHRAE Trans.: Symposia, 21, 2, 1495 (1993).

______________________________________________________________________________

Newer and more accurate correlations for ammonia-water mixture properties are provided in the NIST REFPROP 9 program. REFPROP includes the correlation developed by:

Reiner Tillner Roth, J. Phys. Chem. Ref. Data, Vol. 27 No. 1 (1998).

Information on REFPROP is available at http://www.nist.gov/srd/nist23.cfm

Note that f-Chart Software provides an interface between EES and REFPROP so that you can continue to use EES while accessing the NIST REFPROP data base. See http://fchart.com/ees/ees-refprop.php for more information.