P_1f

Function P_1f returns the economic parameter P_1 for the life-cycle costing method presented in Duffie and Beckman, Solar Engineering of Thermal Processes, 3rd ed., 2006, Wiley.

Inputs:

N number of years considered in the economic analysis

i inflation rate

d market discount rate

c either 1 (for an income producing) or 0 for non-income producing investment

t_bar effective income tax rate

Example:

N=10 [yr]

i=0.035

d=0.04

c=0

t_bar=0

P_1=P_1f(N, i, d, c, t_bar)

P_1 is 9.41.

See also P_2f


P_2f

Function P_2f calculates the economic parameter P_2 for the life-cycle costing method presented in Duffie and Beckman, Solar Engineering of Thermal Processes, 3rd ed., 2006, Wiley.

Inputs:

c either 1 (for an income producing) or 0 for non-income producing investment

d market discount rate

DD ratio of the down payment to the first costs

i general inflation rate

m annual mortgage rate

M_s ratio of maintenance, insurance, and other incidental costs in the first year to the first costs

N number of years considered in the economic analysis

N_L term of the mortgage

N_D depreciation lifetime in years

p property tax rate based on assessed value

R_v ratio of the resale value at the end of the economic period to the first costs

t_bar effective income tax rate

V ratio of assessed value in the first year to the first costs

Example:

c=0

DD=0.2

i=0.035

m=0.065

N_L=10

N_D=10

M_s=0.01

p=0.035

t_bar=0.35

R_v=0

V=1

P_2=P_2f(c, d, DD, i, m, M_s, N, N_L, N_D, p, R_v, t_bar,V)

P_2 is equal to 1.317

See also P_1f