Index

External Flow


External_Flow_Sphere

Procedure External_Flow_Sphere(Fluid$, T_inf, T_s, P, u_inf, D: F_d, h, C_d, Nusselt, Re) calculates the average heat transfer coefficient and drag force and coefficient for external flow past a sphere as detailed in section 4.9.4 of Nellis and Klein . Propeties are evaluated at the film temperature. The units of the inputs and outputs of the procedure depend on the units setting in EES.

Inputs

Fluid$ is a string or string variable that can be any fluid in the EES data base. The fluid can be an ideal gas, a real fluid or an incompressible fluid in the Solid-Liquid_Props fluids library.

T_inf - the free stream fluid temperature in [C], [K], [F], or [R].

T_s - the surface temperature of the sphere in [C], [K], [F], or [R].

P - pressure can be in [Pa], [kPa], [bar], [MPa], [atm] or [psia]. .

u_inf - free stream velocity of the flow in [m/s] or [ft/min]

D - diameter of the sphere in [m] or [ft]

Outputs

F_d - drag force [N] or [lbf]

h - average heat transfer coefficient in [W/m^2-K] or [Btu/hr-ft^2-R]

C_d - drag coefficient [-], where

,

where r is the density of the fluid and Afr is the frontal area.

Nusselt - average Nusselt number [-], where

where k is the conductivity of the fluid

Re - Reynolds number [-], where

where m is the viscosity of the fluid

Notes:

This procedure is responsible for determining the property data of the fluid specified and calculating the Reynold and Prandtl numbers. This procedure then passes the Reynold and Prandtl numbers to the non-dimensional procedure External_Flow_Sphere_ND . The non-dimensional procedure returns the values for C_d and Nusselt. External_Flow_Sphere calculates the drag force and the heat transfer coefficient for convection from the drag coefficient and the Nusselt number,

Example

$unitSystem SI K kPa J

T_s=328 [K]

Fluid$='air'

T_inf=297 [K]

P=101.3 [kPa]

u_inf=10 [m/s]

D=0.01 [m]

Call External_Flow_Sphere(Fluid$, T_inf, T_s, P, u_inf, D: F_d, h, C_d, Nusselt, Re)

{Solution: F_d=0.001747 [N], h=122.8 [W/m^2-K], C_d=0.394 [-], Nusselt=46.22 [-], Re=5,897 [-]}


External_Flow_Sphere_ND

Procedure External_Flow_Sphere_ND(Re,Pr: Nusselt, C_d) returns the average Nusselt number and the drag coefficient for an isothermal sphere of diameter D in crossflow. The propeties are evaluated at the film temperature.

Inputs:

Re - Reynold's number based on properties evaluated at the film temperature [-], defined as

where

r is the density of the fluid

m is the viscosity of the fluid

D is the diameter of the sphere

u_infinity is the velocity of the flow

Pr - Prandtl number of the fluid evaluated at the film temperature [-], defined as

where

cp is the specific heat capacity of the fluid

k is the conductivity

Outputs:

Nusselt - average Nusselt number assuming a constant wall temperature[-]

where

h is the average heat transfer coefficient

C_d - drag coefficient [-]

where

F_D is the drag force

A_fr is the frontal area

Notes

This procedure is called by External_Flow_Sphere to calculate the Nusselt number and drag coefficient. The procedure uses the Whitaker correlation (Whitaker, S., AICHE J., Vol. 18, 361, 1972) as reported in Mills, A.F. Basic Heat and Mass Transfer, Irwin, 1995 and presented in Nellis and Klein . The correlation is valid for Re<7.6E4. The coefficient of drag is based on interpolating experimental data compiled by Schlichting (1968) . Data for the coefficient of drag are available for Reynolds numbers from 0.1 to 1e6.

Example

call External_Flow_Sphere_ND(Re,Pr: Nusselt, C_d)

Re=10000 [-]

Pr=2 [-]

{Solution: Nusselt=101.1 [-] C_d=0.4098 [-]}


External_Flow_Diamond

Procedure External_Flow_Diamond(Fluid$, T_inf, T_s, P, u_inf, W: F_d\L, h, C_d, Nusselt, Re) calculates the average heat transfer coefficient and drag force per unit length of a diamond-shaped rod as well as the drag coefficient, Nusselt and Reynolds numbers in the manner presented in section 4.9.3 of Nellis and Klein. The properties are evaluated at the film temperature and the units of the inputs and outputs correspond to the settings in EES.

Inputs

Fluid$ can be any fluid in the EES data base. The fluid can be an ideal gas, a real fluid or an incompressible fluid in the Solid-Liquid_Props fluids library.

T_inf - the free stream fluid temperature in [C], [K], [F], or [R].

T_s - the surface temperature of the rod in [C], [K], [F], or [R].

P - pressure can be in [Pa], [kPa], [bar], [MPa], [atm] or [psia]. The EES setting is used in property evaluations.

u_inf - free stream velocity of the flow in [m/s] or [ft/min]

W - height of the diamond-shaped rod in [m] or [ft]

L - length of the rod in [m] or [ft]

Outputs

F_d\L - drag force in [N/m] or [lb_f/ft]

h - average heat transfer coefficient in [W/m^2-K] or [Btu/hr-ft^2-R]

C_d - drag coefficient [-], which is defined as

,

where

Afr is the frontal area,

r is the density

Nusselt - average Nusselt number [-], defined as

where

k is the conductivity

Re - Reynolds number [-], defined as

where

m is the viscosity

Notes

This procedure is responsible for determining the property data of the fluid specified and calculating the Reynolds and Prandtl number. This procedure then passes the Reynolds and Prandtl numbers to the non-dimensional procedure External_Flow_Diamond_ND . The non-dimensional procedure then returns the values for C_d and Nusselt. This procedure uses the Nusselt number and drag coefficient to calculate the drag force and the convection heat transfer.

Example

$UnitSystem SI K Pa J

T_s=328 [K]

Fluid$='air'

T_inf=297 [K]

P=101300 [Pa]

u_inf=10 [m/s]

W=0.01 [m]

Call External_Flow_Diamond(Fluid$, T_inf, T_s, P, u_inf, W: F_d\L, h, C_d, Nusselt, Re)

{Solution: F_d\L=0.9035 [N/m], h=96.8 [W/m^2-K], C_d=1.6 [-]}


External_Flow_Diamond_ND

Procedure External_Flow_Diamond_ND(Re,Pr: Nusselt,C_f) returns the average Nusselt number and friction coefficient for flow past an infinitely long diamond-shaped rod.

Inputs:

Re - Reynold's number [-], where

where

r is the density of the fluid

m is the viscosity of the fluid

W is the height of the diamond shaped rod

u_f is the velocity of the flow

Pr - Prandtl number [-], where

where

cp is the specific heat capacity of the fluid

k is the conductivity

Outputs:

Nusselt - average Nusselt number assuming a constant surface temperature[-]. The Nusselt number is defined:

where h_bar is the average heat transfer coefficient

C_D - average drag coefficient [-]. The friction coefficient is defined in terms of the drag force (F):

Notes

The correlation for Nusselt number is valid for 5E3<Re<1E5 as indicated in Table 4-7 of Nellis and Klein . The correlation for the drag coefficient is valid for Re>1E4.

The Reynolds and Prandtl numbers are based on fluid properties evaluated at the film temperature, which is the average of the free stream and the surface temperatures.

References:

Jakob (1949) , White (2003) and Nellis and Klein (2009)

Example

call External_Flow_Diamond_ND(Re,Pr: Nusselt,C_D)

Re=10000 [-]

Pr=0.7 [-]

{Solution: Nusselt=49.12 [-], C_D=1.6}


External_Flow_Square

Procedure External_Flow_Square(Fluid$, T_inf, T_s, P, u_inf, W: F_d\L, h, C_d, Nusselt, Re) calculates the average heat transfer coefficient and drag force per unit length of a square-shaped rod as well as the drag coefficient, Nusselt and Reynolds numbers. The properties are evaluated at the film temperature and the units of the inputs and outputs correspond to the settings in EES.

Inputs

Fluid$ can be any fluid in the EES data base. T The fluid can be an ideal gas, a real fluid or an incompressible fluid in the Solid-Liquid_Props fluids library.

T_inf - the free stream fluid temperature in [C], [K], [F], or [R].

T_s - the surface temperature of the rod in [C], [K], [F], or [R].

P - pressure can be in [Pa], [kPa], [bar], [MPa], [atm] or [psia].

u_inf - free stream velocity of the flow in [m/s] or [ft/min]

W - height of the side of the rod in [m] or [ft]

L - length of the rod in [m] or [ft]

Outputs

F_d\L - drag force in [N/m] or [lb_f/ft]

h - average heat transfer coefficient in [W/m^2-K] or [Btu/hr-ft^2-R]

C_d - drag coefficient [-], which is defined as

,

where

Afr is the frontal area,

r is the density

Nusselt - average Nusselt number [-], defined as

where

k is the conductivity

Re - Reynolds number [-], defined as

where

m is the viscosity

Notes

This procedure is responsible for determining the property data of the fluid specified and calculating the Reynolds and Prandtl numbers. This procedure then passes the Reynolds and Prandtl numbers to the non-dimensional procedure External_Flow_Square_ND . The non-dimensional procedure returns the values for C_d and Nusselt. This procedure uses the Nusselt number and drag coefficient to calculate the drag force and the convection heat transfer coefficient.

Example

$UnitSystem SI K Pa J

T_s=328 [K]

Fluid$='air'

T_inf=297 [K]

P=101300 [Pa]

u_inf=10 [m/s]

W=0.01 [m]

Call External_Flow_Square(Fluid$, T_inf, T_s, P, u_inf, W: F_d\L, h, C_d, Nusselt, Re)

{Solution: F_d\L=1.186 [N/m], h=85.42 [W/m^2-K], C_d=2.1 [-]}


External_Flow_Square_ND

Procedure External_Flow_Square_ND(Re,Pr: Nusselt,C_f) returns the average Nusselt number and friction coefficient for flow past a infinitely long square-shaped rod.

Inputs:

Re - Reynold's number [-], where

where

r is the density of the fluid

m is the viscosity of the fluid

W is the height of the rod

u_f is the velocity of the flow

Pr - Prandtl number [-], where

where

c_p is the specific heat capacity of the fluid

k is the conductivity

Outputs:

Nusselt - average Nusselt number assuming a constant surface temperature[-]. The Nusselt number is defined:

where

h_bar is the average heat transfer coefficient

C_d - average drag coefficient [-]. The friction coefficient is defined in terms of the drag force (F):

Notes

The correlation for Nusselt number is valid for 5E3<Re<1E5. The correlation for the drag coefficient is valid for Re>1E4

The Reynolds and Prandtl numbers are based on fluid properties evaluated at the film temperature, which is the average of the free stream and the surface temperatures.

References:

Jakob (1949) , White (2003) and Nellis and Klein

Example

call External_Flow_Square_ND(Re,Pr: Nusselt,C_d)

Re=10000 [-]

Pr=0.7 [-]

{Solution: Nusselt=45.39 [-], C_D=2.1}


External_Flow_Hexagon1_ND

Procedure External_Flow_Hexagon1_ND(Re,Pr: Nusselt,C_f) returns the average Nusselt number and friction coefficient for flow past a infinitely long hexagon-shaped rod with the flat-edge perpendicular to the flow, as shown.

Inputs:

Re - Reynold's number [-], where

where

r is the density of the fluid

m is the viscosity of the fluid

W is the height of the rod

u_f is the velocity of the flow

Pr - Prandtl number [-], where

where

c_p is the specific heat capacity of the fluid

k is the conductivity

Outputs:

Nusselt - average Nusselt number assuming a constant surface temperature[-]. The Nusselt number is defined:

where

h_bar is the average heat transfer coefficient

C_d - average drag coefficient [-]. The friction coefficient is defined in terms of the drag force (F):

Notes

The correlation for Nusselt number is valid for 5E3<Re<1E5 as described in Table 4-7 of Nellis and Klein . The correlation for the drag coefficient is valid for Re>1E4.

The Reynolds and Prandtl number. are based on fluid properties evaluated at the film temperature, which is the average of the free stream and the surface temperatures.

References:

Jakob (1949) and White (2003)

Example

call External_Flow_Hexagon1_ND(Re,Pr: Nusselt,C_d)

Re=10000 [-]

Pr=0.7 [-]

{Solution: Nusselt=66.76 [-], C_d=0.7}


External_Flow_Hexagon1

Procedure External_Flow_Hexagon1(Fluid$, T_inf, T_s, P, u_inf, W: F_d\L, h, C_d, Nusselt, Re) calculates the average heat transfer coefficient and drag force per unit length of a hexagonal-shaped rod (with the flat face perpendicular to the flow) as well as the drag coefficient, Nusselt and Reynolds numbers. The properties are evaluated at the film temperature and the units of the inputs and outputs correspond to the settings in EES.

Inputs

Fluid$ can be any fluid in the EES data base. The fluid can be an ideal gas, a real fluid or an incompressible fluid in the Solid-Liquid_Props fluids library.

T_inf - the free stream fluid temperature in [C], [K], [F], or [R].

T_s - the surface temperature of the rod in [C], [K], [F], or [R].

P - pressure can be in [Pa], [kPa], [bar], [MPa], [atm] or [psia].

u_inf - free stream velocity of the flow in [m/s] or [ft/min]

W - height of the rod in [m] or [ft]

L - length of the rod in [m] or [ft]

Outputs

F_d\L - drag force in [N/m] or [lb_f/ft]

h - average heat transfer coefficient in [W/m^2-K] or [Btu/hr-ft^2-R]

C_d - drag coefficient [-], which is defined as

,

where

A_fr is the frontal area,

r is the density

Nusselt - average Nusselt number [-], defined as

where

k is the conductivity

Re - Reynolds number [-], defined as

where

m is the viscosity

Notes

This procedure is responsible for determining the property data of the fluid specified and calculating the Reynolds and Prandtl numbers. This procedure then passes the Reynolds and Prandtl number to the non-dimensional procedure External_Flow_Hexagon1_ND . The non-dimensional procedure then returns the values for C_d and Nusselt. This procedure uses the Nusselt number and drag coefficient to calculate the drag force and the convection heat transfer coefficient.

Example

$UnitSystem SI K Pa J

T_s=328 [K]

Fluid$='air'

T_inf=297 [K]

P=101300 [Pa]

u_inf=10 [m/s]

W=0.01 [m]

Call External_Flow_Hexagon1(Fluid$, T_inf, T_s, P, u_inf, W: F_d\L, h, C_d, Nusselt, Re)

{Solution: F_d\L=0.3953 [N/m], h=126.1 [W/m^2-K], C_d=0.7 [-]}


External_Flow_Hexagon2_ND

Procedure External_Flow_Hexagon2_ND(Re,Pr: Nusselt,C_f) returns the average Nusselt number and friction coefficient for flow past a infinitely long hexagon-shaped rod with the flat-edge parallel to the flow, as shown.

Inputs:

Re - Reynold's number [-], where

where

r is the density of the fluid

m is the viscosity of the fluid

W is the height of the rod

u_f is the velocity of the flow

Pr - Prandtl number [-], where

where

c_p is the specific heat capacity of the fluid

k is the conductivity

Outputs:

Nusselt - average Nusselt number assuming a constant surface temperature[-]. The Nusselt number is defined:

where

h_bar is the average heat transfer coefficient

C_d - average drag coefficient [-]. The friction coefficient is defined in terms of the drag force (F):

Notes

The correlation for Nusselt number is valid for 5E3<Re<1E5 as noted in Table 4-7 of Nellis and Klein . The correlation for the drag coefficient is valid for Re>1E4

The Reynolds and Prandtl number are based on fluid properties evaluated at the film temperature, which is the average of the free stream and the surface temperatures.

References:

Jakob (1949) and White (2003)

Example

call External_Flow_Hexagon2_ND(Re,Pr: Nusselt,C_D)

Re=10000 [-]

Pr=0.7 [-]

{Solution: Nusselt=48.42 [-], C_D=1.0}


External_Flow_Hexagon2

Procedure External_Flow_Hexagon2(Fluid$, T_inf, T_s, P, u_inf, W: F_d\L, h, C_d, Nusselt, Re) calculates the average heat transfer coefficient, drag force per unit length of a hexagonal-shaped rod (with the flat face parallel to the flow) as well as the drag coefficient, Nusselt and Reynolds numbers. The properties are evaluated at the film temperature and the units of the inputs and outputs correspond to the settings in EES.

Inputs

Fluid$ can be any fluid in the EES data base. The fluid can be an ideal gas, a real fluid or an incompressible fluid in the Solid-Liquid_Props fluids library.

T_inf - the free stream fluid temperature in [C], [K], [F], or [R].

T_s - the surface temperature of the rod in [C], [K], [F], or [R].

P - pressure can be in [Pa], [kPa], [bar], [MPa], [atm] or [psia].

u_inf - free stream velocity of the flow in [m/s] or [ft/min]

W - height of the rod in [m] or [ft]

L - length of the rod in [m] or [ft]

Outputs

F_d\L - drag force in [N/m] or [lb_f/ft]

h - average heat transfer coefficient in [W/m^2-K] or [Btu/hr-ft^2-R]

C_d - drag coefficient [-], which is defined as

,

where

A_fr is the frontal area,

r is the density

Nusselt - average Nusselt number [-], defined as

where

k is the conductivity

Re - Reynolds number [-], defined as

where

m is the viscosity

Notes

This procedure is responsible for determining the property data of the fluid specified and calculating the Reynolds and Prandtl numbers. This procedure then passes the Reynolds and Prandtl numbesr to the non-dimensional procedure External_Flow_Hexagon2_ND . The non-dimensional procedure then returns the values for C_d and Nusselt. This procedure uses the Nusselt number and drag coefficient to calculate the drag force and the convection heat transfer coefficient

Example

$UnitSystem SI K Pa J

T_s=328 [K]

Fluid$='air'

T_inf=297 [K]

P=101300 [Pa]

u_inf=10 [m/s]

W=0.01 [m]

Call External_Flow_Hexagon2(Fluid$, T_inf, T_s, P, u_inf, W: F_d\L, h, C_d, Nusselt, Re)

{Solution: F_d\L=0.5647 [N/m], h=92.93 [W/m^2-K], C_d=1 [-]}


External_Flow_VerticalPlate

Procedure External_Flow_VerticalPlate(Fluid$, T_inf, T_s, P, u_inf, W: F_d\L, h, C_d, Nusselt, Re) calculates the average heat transfer coefficient and drag force per unit length of vertical plate as well as the drag coefficient, Nusselt and Reynolds numbers. The properties are evaluated at the film temperature and the units of the inputs and outputs correspond to the settings in EES.

Inputs

Fluid$ can be any fluid in the EES data base. The fluid can be an ideal gas, a real fluid or an incompressible fluid in the Solid-Liquid_Props fluids library.

T_inf - the free stream fluid temperature in [C], [K], [F], or [R].

T_s - the surface temperature of the rod in [C], [K], [F], or [R].

P - pressure can be in [Pa], [kPa], [bar], [MPa], [atm] or [psia].

u_inf - free stream velocity of the flow in [m/s] or [ft/min]

W - height of the plate in [m] or [ft]

L - length of the rod in [m] or [ft]

Outputs

F_d\L - drag force in [N/m] or [lb_f/ft]

h - average heat transfer coefficient in [W/m^2-K] or [Btu/hr-ft^2-R]

C_d - drag coefficient [-], which is defined as

,

where

A_fr is the frontal area,

r is the density

Nusselt - average Nusselt number [-], defined as

where

k is the conductivity

Re - Reynolds number [-], defined as

where

m is the viscosity

Notes

This procedure is responsible for determining the property data of the fluid specified and calculating the Reynolds and Prandtl numbers. This procedure then passes the Reynolds and Prandtl numbers to the non-dimensional procedure External_Flow_VerticalPlate_ND . The non-dimensional procedure then returns the values for C_d and Nusselt. This procedure uses the Nusselt number and drag coefficient to calculate the drag force and the convectionheat transfer coefficient.

Example

T_s=328 [K]

Fluid$='air'

T_inf=297 [K]

P=101300 [Pa]

u_inf=10 [m/s]

W=0.01 [m]

Call External_Flow_VerticalPlate(Fluid$, T_inf, T_s, P, u_inf, W: F_d\L, h, C_d, Nusselt, Re)

{Solution: F_d\L=1.129 [N/m], h=310.5 [W/m^2-K], C_d=2 [-]}


External_Flow_VerticalPlate_ND

Procedure External_Flow_VerticalPlate_ND(Re,Pr: Nusselt,C_f) returns the average Nusselt number and friction coefficient for flow past a infinitely long vertical plate of height W.

Inputs:

Re - Reynold's number [-], where

where r is the density of the fluid

m is the viscosity of the fluid

W is the height of the plate

u_f is the velocity of the flow

Pr - Prandtl number [-], where

where cp is the specific heat capacity of the fluid

k is the conductivity

Outputs:

Nusselt - average Nusselt number assuming a constant surface temperature[-]. The Nusselt number is defined:

where h_bar is the average heat transfer coefficient

C_D - average drag coefficient [-]. The friction coefficient is defined in terms of the drag force (F):

Notes

The correlation for Nusselt number is valid for 4E3<Re<1.5E4 as described in . The correlation for the drag coefficient is valid for Re>1E4

The Reynolds and Prandtl number are based on fluid properties evaluated at the film temperature, which is the average of the free stream and the surface temperature.

References:

Jakob (1949) and White (2003)

Example

call External_Flow_VerticalPlate_ND(Re,Pr: Nusselt,C_D)

Re=10000 [-]

Pr=0.7 [-]

{Solution: Nusselt=169.9 [-],C_D=2.0}


External_Flow_Cylinder

Procedure External_Flow_Cylinder(Fluid$, T_inf, T_s, P, u_inf, D: F_d\L, h, C_d, Nusselt, Re) calculates the average heat transfer coefficient, drag force per unit length of cylinder and the drag coefficient for external flow past an infinite cylinder as presented in section 4.9.3 of Nellis and Klein . Properties are evaluated at the film temperature and the units of inputs and outputs depend on the settings in EES.

Inputs

Fluid$ can be any fluid in the EES data base. The fluid can be an ideal gas, a real fluid or an incompressible fluid in the Solid-Liquid_Props fluids library.

T_inf - the free stream fluid temperature in [C], [K], [F], or [R].

T_s - the surface temperature of the cylinder in [C], [K], [F], or [R].

P - pressure can be in [Pa], [kPa], [bar], [MPa], [atm] or [psia].

u_inf - free stream velocity of the flow in [m/s] or [ft/min]

D - diameter of the cylinder in [m] or [ft]

L - length of the cylinder in [m] or [ft]

Outputs

F_d\L - drag force in [N/m] or [lb_f/ft]

h - average heat transfer coefficient in [W/m^2-K] or [Btu/hr-ft^2-R]

C_d - drag coefficient [-], which is defined as

,

where Afr is the frontal area,

r is the density

Nusselt - average Nusselt number [-], defined as

where k is the conductivity

Re - Reynolds number [-], defined as

where m is the viscosity

Notes

This procedure is responsible for determining the property data of the fluid specified and calculating the Reynolds and Prandtl numbers. This procedure then passes the Reynolds and Prandtl numbers to the non-dimensional procedure External_Flow_Cylinder_ND . The non-dimensional procedure then returns the values for C_d and Nusselt. External_Flow_Cylinder calculates the drag force and the heat transfer coefficient for convection from the Nusselt number and drag coefficient,

Example

$unitSystem SI K kPa J

T_s=328 [K]

Fluid$='air'

T_inf=297 [K]

P=101.3 [kPa]

u_inf=10 [m/s]

D=0.01 [m]

Call External_Flow_Cylinder(Fluid$, T_inf, T_s, P, u_inf, D: F_d\L, h, C_d, Nusselt, Re)

{Solution: F_d\L=0.5813 [N/m], h=107.8 [W/m^2-K], C_d=1.029 [-], Nusselt=40.56 [-], Re=5,897 [-]}


External_Flow_Cylinder_ND

Procedure External_Flow_Cylinder_ND(Re,Pr:Nusselt,C_d) returns the average Nusselt number and the drag coefficient for an isothermal cylinder in crossflow. The properties used to calculate the dimensionless numbers should be evaluated at the film temperature.

Inputs:

Re - Reynold's number [-], defined as

where

r is the density of the fluid

m is the viscosity of the fluid

D is the diameter of the cylinder

u_infinity is the velocity of the flow

Pr - Prandtl number [-], defined as

where

c_p is the specific heat capacity of the fluid

k is the conductivity

Outputs:

Nusselt - average Nusselt number assuming a constant wall temperature [-], defined as

where

h is the average heat transfer coefficient

C_d - coefficient of drag [-]

where

F_D is the drag force

A_fr is the frontal area

Notes

This procedure is called by External_Flow_Cylinder to calculate the Nusselt number and drag coefficient. The procedure uses the Churchill and Bernstein correlation(1977) as described in Nellis and Klein . It has been validated at all tested Reynolds numbers with Re*Pr>0.2. The coefficient of drag is based on interpolating experimental data compiled by Schlichting (1968) . Data for the coefficient of drag are available for Reynolds numbers from 0.1 to 1e6.

The Reynolds and Prandtl numbers are based on fluid properties evaluated at the film temperature, which is the average of the free stream and the surface temperatures.

Example

call External_Flow_Cylinder_ND(Re,Pr :Nusselt, C_d)

Re=10000 [-]

Pr=0.8 [-]

{Solution: Nusselt=56.23 [-], C_d=1.248 [-]}


External_Flow_Plate

Procedure External_Flow_Plate(Fluid$, T_inf, T_s, P, V, L: tau, h, C_f, Nusselt, Re) calculates the average heat transfer coefficient and the coefficient of friction for external flow over a flat plate. The propeties are evaluated at the film temperature and the units of the inputs and outputs correspond to the settings in EES. (Note that the shear stress is returned in either Pa or psi units.)

Inputs

Fluid$ can be any fluid in the EES data base. The fluid can be an ideal gas, a real fluid or an incompressible fluid in the Solid-Liquid_Props fluids library.

T_inf - the free stream fluid temperature in [C], [K], [F], or [R].

T_s - the surface temperature of the sphere in [C], [K], [F], or [R].

P - pressure can be in [Pa], [kPa], [bar], [MPa], [atm], or [psia].

u_inf - free stream velocity of flow in [m/s] or [ft/min]

L - length of the plate in [m] or [ft]

Outputs

tau - average shear stress [Pa] or [psi]

h - average heat transfer coefficient in [W/m^2-K] or [Btu/hr-ft^2-R]

C_f - average coefficient of friction [-], defined as:

where

r is the density of the fluid

Nusselt - average Nusselt number [-], defined as:

where

k is the conductivity of the fluid

Re - Reynolds number [-], defined as:

where

m is the viscosity of the fluid

Notes

This procedure determines the property data of the specified fluid and calculatesthe Reynolds and Prandtl numbers. The Prandtl, Reynolds and Nusselt numbers are based on the film temperature, which is the average of the free stream and the surface temperatures. This procedure then passes the Reynolds and Prandtl numbers to the non-dimensional procedure External_Flow_Plate_ND . The non-dimensional procedure then returns the values for C_f and Nusselt and External_Flow_Plate calculates the average shear stress and the convection heat transfer coefficient.

Example

$unitSystem SI K Pa J

T_s=328 [K]

Fluid$='air'

T_inf=297 [K]

P=101300 [Pa]

u_inf=7 [m/s]

L=0.5 [m]

Call External_Flow_Plate(Fluid$, T_inf, T_s, P, u_inf, L: tau, h, C_f, Nusselt, Re)

{Solution: tau=0.08088 [Pa], h=14.15 [W/m^2-K], C_f=0.002923, Nusselt=266.3 [-], Re=206,396 [-]}


External_Flow_Plate_ND

Procedure External_Flow_Plate_ND(Re,Pr: Nusselt,C_f) returns the average Nusselt number and friction coefficient for parallel to a flat plate.

Inputs:

Re - Reynold's number [-], where

where

r is the density of the fluid

m is the viscosity of the fluid

L is the length of the plate

u_infinity is the velocity of the flow

Pr - Prandtl number [-], where

where

c_p is the specific heat capacity of the fluid

k is the conductivity

Outputs:

Nusselt - average Nusselt number assuming a constant wall temperature[-]. The Nusselt number is defined:

where

h is the average heat transfer coefficient

C_f - average friction coefficient [-]. The friction coefficient is defined:

where

t is the average shear stress

Notes

This procedure is called by External_Flow_Plate to calculate the Nusselt number and coefficient of drag. When the flow is laminar(Re<5e5), the Nusselt number is determined by the Churchill and Ozoe (1973) correlation as presented in section 4.9.2 of Nellis and Klein . This correlation is valid for all Prandtl numbers provided that the Peclet number is larger than about 100. When the flow is mixed (Re>5e5), the Nusselt number is calculated using the correlation formulated in Eq. (4-591) of Nellis and Klein . Mixed conditions are assumed in the turbulent region. It is valid for Reynolds numbers above the assumed turbulent transition Reynolds number of 5e5 and below about 1e8. The correlation is best applied to fluids with Prandtl numbers from 0.6<Pr<60.

The Reynolds and Prandtl numbers are based on fluid properties evaluated at the film temperature, which is the average of the free stream and the surface temperatures.

Example

call External_Flow_Plate_ND(Re,Pr: Nusselt,C_f)

Re=10000 [-]

Pr=0.8 [-]

{Solution: Nusselt=60.72 [-], C_d=0.01328}


External_Flow_Inline_Bank

Procedure External_Flow_Inline_Bank(Fluid$, T_in, T_out, T_s, P, u_inf, N_L, D,S_T,S_L: h, DELTAp, Nusselt, Re) calculates the average heat transfer coefficient, and total pressure drop over a staggered bank of tubes. Properties are evaluated at the film temperature and the units of the inputs and outputs correspond to the settings in EES.

Inputs

Fluid$ can be any fluid in the EES data base. The fluid can be an ideal gas, a real fluid or an incompressible fluid in the Solid-Liquid_Props fluids library.

T_in - the free stream fluid temperature at the inlet in [C], [K], [F], or [R].

T_out - the free stream fluid temperature at the outlet in [C], [K], [F], or [R].

T_s - the surface temperature of the sphere in [C], [K], [F], or [R].

P - pressure can be in [Pa], [kPa], [bar], [MPa], [atm], or [psia]. T

u_inf - free stream velocity of flow in [m/s] or [ft/min]

N_L - the number of rows of tubes

D - tube diameter in [m] or [ft]

S_T is the transverse tube pitch in [m] or [ft]

S_L is the longitudinal tube pitch in [m] or [ft]

Outputs

h - average heat transfer coefficient in [W/m^2-K] or [Btu/hr-ft^2-R]

deltap - total pressure drop in the pressure units set in the EES Unit System dialog

Nusselt - average Nusselt number [-], defined as

Re - Reynolds number [-], defined as

Notes

The procedure uses correlations and correction factors provided by Žukauskas (1972) . These correlations apply for values of Reynolds numbers from ~30<Re<1e8 and Prandtl numbers from ~0.7<Pr<500. At Reynolds numbers 100<Re<1000, the heat transfer coefficient can be calculated assuming a single cylinder in crossflow. Under those conditions the Churchill and Bernstein correlation(1977) is used.

Experimental data verifying the correlations are limited in geometric layout to relative longitudinal pitches (S_L/D) between 1.25 and 2.5. The accuracy of values outside this range is uncertain.

The Reynolds and Prandtl number are based on fluid properties evaluated at the film temperature, which is the average of the free stream and the surface temperature.

Example

$unitSystem SI K Pa J

T_s=328 [K]

Fluid$='air'

P=101300 [Pa]

u_inf=0.9 [m/s]

D=0.5 [m]

T_in=370 [K]

T_out=350 [K]

N_L=13

S_T=1.1 [m]

S_L=1.0 [m]

Call External_Flow_Inline_Bank(Fluid$, T_in, T_out, T_s, P, u_inf, N_L, D,S_T,S_L: h, DELTAp, Nusselt, Re)

{Solution: h=10.79 [W/m^2-K], DELTAp=55.24 [Pa], Nusselt=179.7 [-], Re=38,058 [-]}


External_Flow_Staggered_Bank

Procedure External_Flow_Staggered_Bank(Fluid$, T_in, T_out, T_s, P, u_inf, N_L, D,S_T,S_L: h, DELTAp, Nusselt, Re) calculates the average heat transfer coefficient, and total pressure drop over a staggered bank of tubes. Properties are evaluated at the film temperature and the units of the inputs and outputs correspond to the settings in EES.

Inputs

Fluid$ can be any fluid in the EES data base. The fluid can be an ideal gas or a real fluid.

T_in - the free stream fluid temperature at the inlet in [C], [K], [F], or [R].

T_out - the free stream fluid temperature at the outlet in [C], [K], [F], or [R].

T_s - the surface temperature of the sphere in [C], [K], [F], or [R].

P - pressure can be in [Pa], [kPa], [bar], [MPa], [atm] or [psia].

u_inf - free stream velocity of flow in [m/s] or [ft/min]

N_L - the number of rows of tubes

D - tube diameter in [m] or [ft]

S_T is the transverse tube pitch in [m] or [ft]

S_L is the longitudinal tube pitch in [m] or [ft]

Outputs

h - average heat transfer coefficient in [W/m^2-K] or [Btu/hr-ft^2-R]

deltap - total pressure drop in the pressure units set in the EES Unit System dialog

Nusselt - average Nusselt number [-], defined as

Re - Reynolds number [-], defined as

, with V_max occuring in either the transverse or diagonal plane

Notes

The procedure uses correlations and correction factors provided by Žukauskas (1972) . These correlations apply for values of Reynolds numbers from ~30<Re<1e8 and Prandtl numbers from ~0.7<Pr<500. At Reynolds numbers 100<Re<1000, the coefficient of heat transfer can be calculated assuming a single cylinder in crossflow. Under those conditions the Churchill and Bernstein correlation(1977) is used.

Experimental data verifying the correlations are limited in geometric layout to relative transverse pitches (S_T/D) between 1.25 and 2.5. The accuracy of values outside this range is uncertain.

The Reynolds and Prandtl number are based on fluid properties evaluated at the film temperature, which is the average of the free stream and the surface temperature.

Example

$unitSystem SI K Pa J

T_s=328 [K]

Fluid$='air'

P=101300 [Pa]

u_inf=0.9 [m/s]

D=0.5 [m]

T_in=370 [K]

T_out=350 [K]

N_L=13

S_T=1.1 [m]

S_L=1.0 [m]

Call External_Flow_Staggered_Bank(Fluid$, T_in, T_out, T_s, P, u_inf, N_L, D,S_T,S_L: h, DELTAp, Nusselt, Re)

{Solution: h=10.39 [W/m^2-K], DELTAp=67.87 [Pa], Nusselt=173.1 [-], Re=38,058 [-]}


Incropera and DeWitt (2002)

Incropera, F.P. and DeWitt, D.P., Introduction to Heat Transfer, 4th Ed., Wiley, 2002


Kakaç et al. (1987)

Kakaç, S, Shah, R.K, and Aung, W., "Handbook of Single-Phase Convective Heat Transfer,", Wiley, 1987


Schlichting (1968)

Schlichting, H. Boundary Layer Theory, 6th ed. McGraw-Hill, New York, 1968. in Incropera, F.P. and DeWitt, D.P., Introduction to Heat Transfer, 4th Ed., Wiley, 2002.


Churchill and Bernstein (1977)

Churchill, S.W., and Bernstein, M. (1977). A Correlating Equation for Forced Convection from Gases and Liquids to a Circular Cylinder in Cross Flow, J. Heat Transfer, 99, 300-306. in Bejan, Adrian; Kraus, Allan D. Heat Transfer Handbook. John Wiley & Sons. Online version available at: http://www.knovel.com/knovel2/Toc.jsp?BookID=725&VerticalID=0


Churchill and Ozoe (1973)

Churchill, S.W., and H, Ozoe, J. Heat Transfer, 95, 78, 1973. in Incropera, F.P. and DeWitt, D.P., Introduction to Heat Transfer, 4th Ed., Wiley, 2002.


Zukauskas (1972)

Žukauskas (1972)

Žukauskas, A., "Heat Transfer from Tubes in Crossflow," in J.P. Harnett and T. F. Invine, Jr., Eds., Advances in Heat Transfer, Vol. 8, Academic Press, New York, 1972.


Jacob (1949)

Jakob (1949)

Jakob M., 1949, Heat Transfer, John Wiley & Sons, New York.


White (2003)

White, Frank M. (2003). Fluid Mechanics. McGraw-Hill. ISBN 0072402172


Nellis and Klein

Heat Transfer

G.F. Nellis and S.A. Klein

Cambridge University Press, 2009