Index

Internal Flow

Dimensional

Non-Dimensional

Local (Dimensional)

Local (Non-Dimensional)

Pipe Sizes


PipeFlow

Procedure PipeFlow( Fluid$, T, P, m_dot, D, L,RelRough: h_T, h_H, DELTAP, Nusselt_T, f, Re) returns lower and upper bounds on the average heat transfer coefficient and the pressure drop for a specified mass flow rate (m_dot) through a circular tube of diameter D and length L. The procedure assumes simultaneous hydrodynamic and thermally developing flow as reported in Section 5.2.3 of Nellis and Klein . Properties are evaluated at the bulk temperature T and pressure P. Units of the inputs and outputs depend upon the unit settings in EES.

Inputs:

Fluid$ can be any fluid in the EES database. The fluid can be an ideal gas or a real fluid.

T - the bulk temperature of the fluid in [C], [K], [F], or [R].

P - pressure can be in [Pa], [kPa], [bar], [MPa], [atm], or [psia].

m_dot - mass flow rate in [kg/s], or [lbm/hr]

D - diameter of the tube in [m] or [ft]

L - length of the tube in [m] or [ft]

RelRough - the ratio of the dispersions on the wall of the tube to the tube diameter (must be between 0 and 0.05)

Outputs (all but the first output are optional):

h_T - heat transfer coefficient in [W/m^2-K] or [Btu/hr-ft^2-R] assuming that the pipe wall is at constant temperature (lower bound)

h_H - heat transfer coefficient in [W/m^2-K] or [Btu/hr-ft^2-R] assuming a constant heat flux at the pipe wall (upper bound)

DELTAP - pressure difference between the inlet and outlet of the pipe in the pressure units set in the EES Unit System dialog

Nusselt_T - Nusselt number (determined for a constant temperature wall) [-]

f - friction factor [-]

Re - Reynolds number [-]

Notes

This procedure calculates the Reynolds and Prandtl numbers and then calls PipeFlow_N .

Two values of the heat transfer coefficient are returned. The first, h_T is determined assuming that the wall is at constant temperature. The second is determined assuming that the wall is subjected to a constant heat flux. For laminar flow, these values should provide lower and upper bounds on the heat transfer coefficient. For turbulent flow, these values are identical.

The procedure will determine if the flow is laminar or turbulent. Transitional flow is assumed to occur for Reynold's numbers between 2300 and 3000 and interpolation is applied between the laminar and turbulent correlations. The ratio of L/D is used to apply a developing flow correction based on simultaneous hydrodynamic and thermal development; set L to a large number if developing flow corrections are not applicable.

Example

$UnitSystem SI K Pa J

T=363 [K] "average temperature of fluid in pipe"

P=101300 [Pa] "pressure of air in pipe"

m_dot=0.05 [kg/s] "flow rate"

D=0.15 [m] "pipe diameter"

L=500 [m] "pipe length"

RelRough=0 "relative roughness"

call PipeFlow('Air', T, P, m_dot, D, L,RelRough: h_T, h_H, DELTAP, Nusselt_T, f, Re)

{Solution:

DELTAP=357 [Pa]

f=0.02601 [-]

h_H=10.32 [W/m^2-K]

h_T=10.32 [W/m^2-K]

Nusselt_T=51.21 [-]

Re=19,851 [-]

}


PipeFlow_local

Procedure PipeFlow_local( Fluid$, T, P, m_dot, D, x, RelRough: h_T_x, h_H_x, dPdx) returns lower and upper bounds on the local heat transfer coefficient and the local pressure gradient at axial position x for a specified mass flow rate (m_dot) through a circular tube of diameter D and length L. The pressure gradient is expressed in the EES pressure unit (Pa, kPa, bar, MPa, psi, atm) per m or ft, depending on whether EES is configured in SI or English units. This procedure calls PipeFlow to obtain the integrated values. Properties are evaluated at the bulk temperature T and pressure P.

Inputs:

Fluid$ can be any fluid in the EES database. The fluid can be an ideal gas or a real fluid.

T - the bulk temperature of the fluid at location x in [C], [K], [F], or [R].

P - pressure at location x in [Pa], [kPa], [bar], [MPa], [atm], or [psia].

m_dot - mass flow rate in [kg/s], or [lbm/hr]

D - diameter of the tube in [m] or [ft]

x - position in the axial direction of the tube in [m] or [ft]

RelRough - the ratio of the dispersions on the wall of the tube to the tube diameter (must be between 0 and 0.05)

Outputs (all but the first output are optional):

h_T_x - local heat transfer coefficient in [W/m^2-K] or [Btu/hr-ft^2-R] assuming that the pipe wall is at constant temperature (lower bound)

h_H_x - local heat transfer coefficient in [W/m^2-K] or [Btu/hr-ft^2-R] assuming a constant heat flux at the pipe wall (upper bound)

dPdx - local pressure gradient. [(Pa, kPa, bar, or atm)/m] or [(psi or atm)/ft] depending on EES pressure unit setting

Notes

This procedure differentiates the average heat transfer coefficient and pressure gradient provided by procedure PipeFlow .

Two values of the local heat transfer coefficient are returned. The first, h_T_x is determined assuming that the wall is at constant temperature. The second (h_H_x) is determined assuming that the wall is subjected to a constant heat flux. For laminar flow, these values should provide lower and upper bounds on the heat transfer coefficient. For turbulent flow, these values are identical. See PipeFlow or section 5.2 of Nellis and Klein for additional information.

Example

$UnitSystem SI K Pa J

T=363 [K] "temperature of fluid in pipe"

P=101300 [Pa] "pressure of air in pipe"

m_dot=0.05 [kg/s] "flow rate"

D=0.15 [m] "pipe diameter"

x =5 [m] "position in pipe"

RelRough=0 [-] "relative roughness"

call PipeFlow_Local('Air', T, P, m_dot, D, x,RelRough: h_T_x, h_H_x, dPdx)

{Solution:

dPdx=-0.7299 [Pa/m]

h_H_x=10.55 [W/m^2-K]

h_T_x=10.55 [W/m^2-K]}


PipeFlow_N

Procedure PipeFlow_N(Re, Pr, LoverD, RelRough: Nusselt_T, Nusselt_H, f) returns the average Nusselt number assuming constant temperature wall and constant heat flux for a given flow condition in a circular tube characterized by Reynolds and Prandtl numbers, length/diameter, and relative roughness. The Procedure also returns the friction factor for these conditions. The procedure can be used for developing or fully-developed flow in the laminar, transitional or turbulent flow regimes.

Inputs:

Re - Reynolds number based on properties evaluated at the bulk average temperature

Pr - Prandtl number of the fluid evaluated at the bulk average temperature

LoverD - ratio of tube length to diameter.

RelRough - the ratio of the dispersions on the wall of the tube to the tube diameter (must be between 0 and 0.05)

Outputs:

Nusselt_T - average Nusselt number assuming a constant wall temperature

Nusselt_H - average Nusselt number assuming a constant wall heat flux

f - apparent friction factor [-]

Notes

This procedure is called by PipeFlow . It calls PipeFlow_Laminar and PipeFlow_Turbulent to obtain the appropriate Nusselt numbers and friction factor.

The procedure will determine if the flow is laminar or turbulent. Transitional flow is assumed to occur for Reynold's numbers between 2300 and 3000 and interpolation is applied between the laminar and turbulent correlations.

The ratio LoverD is used to apply a developing flow correction based on simultaneous thermal and hydrodynamic development. Set LoverD to a large number if developing flow corrections are not applicable. Set the Prandtl number to a large value to obtain results that are consistent with thermally developing/hydrodynamically developed conditions for laminar flows.

Two Nusselt numbers are returned. Nusselt_T corresponds to a constant temperature wall and Nusselt_H corresponds to a constant heat flux. These two values will be the same for turbulent flow. For laminar flow, they provide upper and lower bounds on the Nusselt number as explained in Section 5.2.4 of Nellis and Klein .

Example

Re=10000

Pr=2

LoverD=100

relRough=0

call PipeFlow_N(Re,Pr,LoverD,RelRough: Nusselt_T,Nusselt_H,f)

{Solution

f=0.03211 [-]

Nusselt_H=49.37

Nusselt_T=49.37 [-]}


PipeFlow_turbulent

Procedure PipeFlow_turbulent (Re, Pr, LoverD, RelRough: Nusselt, f) returns the average Nusselt number and friction factor for a circular tube characterized by Reynolds and Prandtl numbers, length/diameter, and relative roughness. The Reynold's number is expected to be > 2300.

Inputs:

Re - Reynolds number based on properties evaluated at the bulk average temperature

Pr - Prandtl number of the fluid evaluated at the bulk average temperature

LoverD - ratio of tube length to diameter.

RelRough - the ratio of the dispersions on the wall of the tube to the tube diameter (must be between 0 and 0.05)

Outputs:

Nusselt - average Nusselt number

f - apparent friction factor [-]

Notes

The friction factor for a smooth tube is determined using the Li, Seem, and Li (2011) correlation.

The friction factor for a rough tube is determined using the Zigrang and Sylvester (1982) correlation.

The effect of developing flow is accounted for by multiplying the fully developed value of the friction factor by (1+C/(LoverD)^m) where

C = 1 and m = 0.7.

The Gnielinski correlation (1976) as reported in Section 5.2.4 of Nellis and Klein is used for turbulent flow in smooth tubes.

The Chilton-Colburn analogy based on the Churchill friction factor is used for rough tubes.

The effect of developing flow is accounted for by multiplying the fully developed value of the Nusselt number by (1+C/(LoverD)^m) where

C = 1 and m = 0.7.


PipeFlow_Laminar

Procedure PipeFlow_laminar (Re, Pr, LoverD: Nusselt_T, Nusselt_H, f) returns the average Nusselt number and friction factor for a circular tube characterized by Reynolds and Prandtl numbers, length/diameter, and relative roughness. The Reynold's number is expected to be < 2300.

Inputs:

Re - Reynolds number based on properties evaluated at the bulk average temperature [-]

Pr - Prandtl number of the fluid evaluated at the bulk average temperature [-]

LoverD - ratio of tube length to diameter.

Outputs:

Nusselt_T - average Nusselt number assuming a constant wall temperature

Nusselt_H - average Nusselt number assuming a constant wall heat flux

f - apparent Darcy friction factor [-]

Notes

The Darcy friction factor is calculated using a correlation recommended in Eqn 192, p98 of Shah and London (1978) . The correlation is applicable in the developing and fully-developed region and limits to 64/Re.

The average Nusselt number correlations were fit to data provided in Tables 20 and 22 of Shah and London (1978) based on data from Hornbeck (1965) . Table 22 Shah and London provides only the local Nusselt number. The local values were integrated to obtained average values which were used to establish the correlation as reported in Section 5.2.4 of Nellis and Klein . The average Nusselt numbers assume simultaneously developing flow; however, it is possible to obtain values consistent with thermally developing/hydrodynamically developed flow by calling the procedure with a large Prandtl number.


PipeFlow_N_local

Procedure PipeFlow_N_local(Re, Pr, xoverD, RelRough: Nusselt_T_x, Nusselt_H_x, f_x) returns the local Nusselt numbers assuming constant temperature wall and constant heat flux for a given flow condition a circular tube characterized by Reynolds and Prandtl numbers,axial position/diameter, and relative roughness. The Procedure also returns the local friction factor for these conditions. The procedure can be used for developing or fully-developed flow in the laminar, transitional or turbulent flow regimes.

Inputs:

Re - Reynolds number based on pipe diameter and the properties evaluated at the local bulk average temperature

Pr - Prandtl number of the fluid evaluated at the local bulk average temperature

xoverD - ratio of axial position to diameter.

RelRough - the ratio of the dispersions on the wall of the tube to the tube diameter (must be between 0 and 0.05)

Outputs:

Nusselt_T_x - local Nusselt number assuming a constant wall temperature

Nusselt_H_x - local Nusselt number assuming a constant wall heat flux

f_x - local friction factor [-]

Notes

This procedure determines the local Nusselt numbers and friction factor by differentiating the average values provided by the PipeFlow_N procedure. See PipeFlow_N for more information.

The Nusselt numbers approach infinity as xoverD goes to 0. The correlations are not applicable for xoverD ratios less than 0.1.

Two Nusselt numbers are returned. Nusselt_T corresponds to a constant temperature wall and Nusselt_H corresponds to a constant heat flux. These two values will be the same for turbulent flow. For laminar flow, they provide upper and lower bounds on the Nusselt number.

Example

Re=1000

Pr=2

xoverD=1.1

relRough=0

call PipeFlow_N_local(Re,Pr,xoverD,RelRough: Nusselt_T_x,Nusselt_H_x, f_x)

{Solution:

f_x=0.2156 [-]

Nusselt_T_x=14.03 [-]

Nusselt_H_x=20.05 [-]}


DuctFlow

Procedure DuctFlow( Fluid$, T, P, m_dot, H, W, L, RelRough: h_T, h_H, DELTAP, Nusselt_T, f, Re) returns a lower and upper bound on the average heat transfer coefficient and the pressure drop for mass flow m_dot through a rectangular duct of height H, width W, and length L. The procedure is applicable for simultaneous hydrodynamic and thermally developing flow or for fully-developed flow in the laminar, transitional or turbulent flow regimes. Properties are evaluated at a bulk temperature T and pressure P and used to calculate the Reynolds and Prandtl numbers. Units of the inputs and outputs depend upon the unit settings in EES.

Inputs:

Fluid$ can be any fluid in the EES database. The fluid can be an ideal gas or a real fluid.

T - the bulk temperature of the fluid in [C], [K], [F], or [R].

P - pressure can be in [Pa], [kPa], [bar], [MPa], [atm], or [psia].

m_dot - mass flow rate in [kg/s] or [lbm/hr]

H - duct height [m] or [ft]

W - duct width [m] or [ft]

L - length of the duct [m] or [ft]

RelRough - the ratio of the dispersions on the walls of the duct to the hydraulic diameter of the duct (must be between 0 and 0.05). The hydraulic diameter is 2 W H/(W + H).

Outputs:

h_T - heat transfer coefficient in [W/m^2-K] or [Btu/hr-ft^2-R] assuming that the duct wall is at constant temperature (lower bound)

h_H - heat transfer coefficient in [W/m^2-K] or [Btu/hr-ft^2-R] assuming a constant heat flux at the duct wall (upper bound)

DELTAP - pressure difference between the inlet and outlet of the duct in the pressure units set in the EES Unit System dialog

Nusselt_T - Nusselt number determined for a constant temperature duct wall

f - friction factor [-]

Re - Reynolds number [-]

Notes:

This procedure calculates the Reynolds and Prandtl numbers and then calls DuctFlow_N , which determines the Nusselt numbers associated with constant temperature and constant flux.

Two values of the heat transfer coefficient are returned. The first, h_T is determined assuming that the wall is at constant temperature. The second is determined assuming that the wall is subjected to a constant heat flux. For laminar flow, these values should provide lower and upper bounds on the heat transfer coefficient. For turbulent flow, these values are identical.

The procedure will determine if the flow is laminar or turbulent. Transitional flow is assumed to occur for Reynold's numbers between 2300 and 3000 and interpolation is applied between the laminar and turbulent correlations.

The value of the heat transfer coefficient that is returned by this procedure is applicable for simultaneous development of the thermal and hydrodynamic boundary layers in the laminar flow regime. See Section 5.2.4 of Nellis and Klein for more information.

The Graetz number (Re Pr D / L) is used to determine the correction for developing flow assuming a simultaneous thermal and hydrodynamic development; set L to a large number if developing flow corrections are not applicable.

Example:

$unitSystem SI Pa K J

T=363 [K] "average temperature of fluid in duct"

P=101300 [Pa] "pressure of air in duct"

m_dot=0.005 [kg/s] "flow rate"

H=0.1 [m] "duct height"

W=0.5 [m] "duct width"

L=5 [m] "duct length"

RelRough=0.005 [-] "relative roughness"

call DuctFlow('air',T,P,m_dot,H,W,L,RelRough:h_T, h_H ,DELTAP, Nusselt_T, f, Re)

{Solution:

DELTAP=0.02058 [Pa]

f=0.1334 [-]

h_H=1.429 [W/m^2-K]

h_T=1.051 [W/m^2-K]}


DuctFlow_local

Procedure DuctFlow_local(Fluid$, T, P, m_dot, H, W, x, RelRough: h_T_x, h_H_x, dPdx) returns lower and upper bounds on the local heat transfer coefficient and the local pressure gradient at axial position x for a specified mass flow rate (m_dot) through a rectangular duct of height H and width W. The procedure assumes simultaneous hydrodynamic and thermally developing flow. Properties are evaluated at the bulk temperature T and pressure P. Units of the inputs and outputs depend upon the unit settings in EES.

Inputs:

Fluid$ can be any fluid in the EES database. The fluid can be an ideal gas or a real fluid.

T - the bulk temperature of the fluid at location x in [C], [K], [F], or [R].

P - pressure at location x in [Pa], [kPa], [bar], [MPa], [atm], or [psia].

m_dot - mass flow rate in [kg/s], or [lbm/hr]

H - duct height [m] or [ft]

W - duct width [m] or [ft]

x - position in the axial direction of the tube in [m] or [ft]

RelRough - the ratio of the dispersions on the wall of the tube to the tube diameter (must be between 0 and 0.05)

Outputs (all but the first output are optional):

h_T_x - local heat transfer coefficient in [W/m^2-K] or [Btu/hr-ft^2-R] assuming that the duct wall is at constant temperature (lower bound)

h_H_x - local heat transfer coefficient in [W/m^2-K] or [Btu/hr-ft^2-R] assuming a constant heat flux at the duct wall (upper bound)

dPdx - local pressure gradient. [(Pa, kPa, bar, or atm)/m] or [(psi or atm)/ft] depending on EES pressure unit setting

Notes

This procedure differentiates the average heat transfer coefficient and pressure gradient provided by procedure DuctFlow .

Two values of the local heat transfer coefficient are returned. The first, h_T_x is determined assuming that the wall is at constant temperature. The second (h_H_x) is determined assuming that the wall is subjected to a constant heat flux. For laminar flow, these values should provide lower and upper bounds on the heat transfer coefficient as discussed in Section 5.2.4 of Nellis and Klein . For turbulent flow, these values are identical.

Example

$unitSystem SI Pa K J

T=363 [K] "average temperature of fluid in pipe at location x"

P=101.3 [Pa] "pressure of air in pipe"

m_dot=0.05 [kg/s] "flow rate"

x=5 [m] "location along axial direction"

RelRough=0 [-] "relative roughness"

H=0.1 [m] "height"

W=0.2 [m] "width"

call ductFlow_local( 'Air', T, P, m_dot, H,W, x,RelRough: h_T_x, h_H_x, dPdx)

{Solution:

dPdx=-679.4 [Pa/m]

h_H_x=9.786 [W/m^2-K]

h_T_x=9.786 [W/m^2-K]}


DuctFlow_N

Procedure DuctFlow_N(Re, Pr, LoverD_h, Aspect, relRough: Nusselt_T,Nusselt_H, f) returns the average Nusselt number assuming constant temperature wall and constant heat flux for a given flow condition in a rectangular duct characterized by Reynolds and Prandtl numbers, length/hydraulic diameter, aspect ratio, and relative roughness. The procedure also returns the friction factor for these conditions. The procedure can be used for simultaneous thermal and hydrodynamic developing flow or fully-developed flow in the laminar, transitional or turbulent flow regimes.

Inputs:

Re - Reynolds number based on properties evaluated at the bulk average temperature

Pr - Prandtl number of the fluid evaluated at the bulk average temperature

LoverD_h - ratio of tube length to hydraulic diameter.

Aspect - ratio of the minimum to maximum dimension of duct. This value should be <=1

RelRough - the ratio of the dispersions on the wall of the tube to the tube diameter (must be between 0 and 0.05)

Outputs:

Nusselt_T - Nusselt number assuming a constant wall temperature

Nusselt_H - Nusselt number assuming a constant wall heat flux

f - apparent friction factor [-]

Notes:

This procedure is called by DuctFlow . It calls DuctFlow_Laminar and PipeFlow_Turbulent to obtain the appropriate Nusselt numbers and the friction factor.

The procedure will determine if the flow is laminar or turbulent. Transitional flow is assumed to occur for Reynolds numbers (based on hydraulic diameter) between 2300 and 3000 and interpolation is applied between the laminar and turbulent correlations.

The parameter LoverD_h is used to apply a developing flow correction if necessary. Set LoverD_h to a large number if developing flow corrections are not applicable.

Two Nusselt numbers are returned. Nusselt_T corresponds to a constant temperature wall and Nusselt_H corresponds to a constant heat flux. These two values will be the same for turbulent flow. For laminar flow, they provide upper and lower bounds on the Nusselt number as discussed in Section 5.2.4 of Nellis and Klein .

The procedure assumes simultaneous development of the thermal and hydrodynamic boundary layers; however, the results for a thermally developing/hydrodynamically developed laminar flow can be obtained by calling the procedure with a large Prandtl number.

Example:

Re=4500

Pr=2

Aspect=0.25

LoverD_h=20

relRough=0

call DuctFlow_N(Re,Pr,LoverD_h,Aspect,RelRough: Nusselt_T, Nusselt_H, f)

{Solution:

f=0.0433 [-]

Nusselt_H=24.96

Nusselt_T=24.96 [-]}


DuctFlow_Laminar

Procedure DuctFlow_Laminar(Re,Pr,LoverD_h,Aspect: Nusselt_T, Nusselt_H, f) returns the average Nusselt number and friction factor for a rectangular duct characterized by Reynolds and Prandtl numbers, length/diameter, and aspect ratio. The Reynold's number is expected to be < 2300.

Inputs:

Re - Reynolds number based on properties evaluated at the bulk average temperature

Pr - Prandtl number of the fluid evaluated at the bulk average temperature

LoverD_h - ratio of tube length to hydraulic diameter.

Aspect - ratio of the minimum to the maximum dimensions of the channel (Aspect <=1)

Outputs (all but the first output are optional):

Nusselt_T - average Nusselt number assuming a constant wall temperature

Nusselt_H - average Nusselt number assuming a constant wall heat flux

f - apparent Darcy friction factor [-] .

Notes:

The Darcy friction factor is calculated using a correlation recommended in Eqn 3.158, p. 3.46 of Kakaç et al . The correlation is strictly applicable in the fully-developed region, but is used here for the developing region as well by correcting it using the form provided by Shah and London .

The average Nusselt number for constant wall temperature and constant wall heat flux are based on interpolated data from Table 3.17 of Kakaç et al . The data in this table corresponding to the developing region of the thermal and hydrodynamic boundary layers are for a Prandtl number of 0.72. The values are adjusted for other Prandtl numbers using interpolated data in Table 3.18 of Kakaç et al which is for a square duct with a constant wall heat flux; however, the correction factor obtained for this situation is applied to all ducts, independent of aspect ratio or boundary condition.

Results for a thermally developing/hydrodynamically developed flow can be obtained by calling the procedure with a large Prandtl number.

Set Aspect to zero to obtain the Nusselt number for flow between parallel plates.


DuctFlow_N_local

Missing image: ductflow_n_local.bmp

Procedure DuctFlow_N_local(Re, Pr, xoverD_h, Aspect, relRough: Nusselt_T_x,Nusselt_H_x, f_x) returns the local Nusselt number assuming constant temperature wall and constant heat flux for a given flow condition in a rectangular duct characterized by Reynolds and Prandtl numbers, local position/hydraulic diameter, aspect ratio, and relative roughness. The procedure also returns the friction factor for these conditions. The procedure can be used for simultaneous thermal and hydrodynamic developing flow or fully-developed flow in the laminar, transitional or turbulent flow regimes.

Inputs:

Re - Reynolds number based on properties evaluated at the bulk average temperature

Pr - Prandtl number of the fluid evaluated at the bulk average temperature

xoverD_h - ratio of axial position to hydraulic diameter.

Aspect - ratio of the minimum to maximum dimension of duct. This value should be <=1

RelRough - the ratio of the dispersions on the wall of the tube to the tube diameter (must be between 0 and 0.05)

Outputs (all but the first output are optional):

Nusselt_T_x -local Nusselt number assuming a constant wall temperature

Nusselt_H_x - local Nusselt number assuming a constant wall heat flux

f_x - apparent local friction factor [-]

Notes:

This procedure calls DuctFlow_N to obtain the average Nusselt numbers and frection factor. See that routine or Section 5.2.4 of Nellis and Klein for additional information.

Two Nusselt numbers are returned. Nusselt_T_x corresponds to a constant temperature wall and Nusselt_H_x corresponds to a constant heat flux. These two values will be the same for turbulent flow. For laminar flow, they provide upper and lower bounds on the Nusselt number.

The procedure assumes simultaneous development of the thermal and hydrodynamic boundary layers; however, the results for a thermally developing/hydrodynamically developed condition can be obtained by calling the procedure with a large Prandtl number.

Example:

Re=4500

Pr=2

Aspect=0.25

xoverD_h=20

relRough=0

call DuctFlow_N_local(Re, Pr, xoverD_h, Aspect, RelRough: Nusselt_T_x, Nusselt_H_x, f_x)

{Solution:

f_x=0.03999

Nusselt_H_x=23.05 [-]

Nusselt_T_x=23.05 [-]}


AnnularFlow

Procedure AnnularFlow( Fluid$, T, P, m_dot, r_i, r_o, L, RelRough: h_T, h_H, DELTAP, Nusselt_T, f, Re) returns the lower and upper bounds on the convection coefficient for flow in an annular duct. The outer wall of the annulus is assumed to be insulated so heat transfer occurs across the wall separating the annulus from the pipe. The area used for heat transfer should be the area of this wall. The procedure also returns the friction factor for these conditions.

Inputs:

Fluid$ can be any fluid in the EES database. The fluid can be an ideal gas or a real fluid.

T - the bulk temperature of the fluid [C], [K], [F], or [R].

P - pressure can be in [Pa], [kPa], [bar], [MPa], [atm], or [psia].

m_dot - mass flow rate in [kg/s] or [lbm/hr]

r_i - inner radius of annulus [m] or [ft]

r_o - outer radius of annulus [m] or [ft]

L - length of the annulus [m] or [ft]

RelRough - the ratio of the dispersions on the walls of the duct to the hydraulic diameter of the duct (must be between 0 and 0.05). The hydraulic diameter is 2 W H/(W + H).

Outputs:

h_T - lower bound heat transfer coefficient in [W/m^2-K] or [Btu/hr-ft^2-R] assuming that the inner annulus wall is at constant temperature

h_H - upper bound on heat transfer coefficient in [W/m^2-K] or [Btu/hr-ft^2-R] assuming a constant heat flux at the inner annulus wall

DELTAP - pressure difference between the inlet and outlet of the annular space in the pressure units set in the EES Unit System dialog

Nusselt_T - Nusselt number corresponding to the lower heat transfer coefficient.l

f - friction factor [-]

Re - Reynolds number

Notes:

This procedure calculates the Reynolds and Prandtl numbers and then calls AnnularFlow_N which determines the Nusselt numbers based on boundary conditions of constant temperature and constant heat flux individually.

Two values of the heat transfer coefficient are returned that should provide upper and lower bounds. These heat transfer coefficients are both for the inner annular wall with an insulated outer wall. For turbulent flow, these values are identical.

The procedure will determine if the flow is laminar or turbulent. Transitional flow is assumed to occur for Reynold's numbers between 2300 and 3000 and interpolation is applied between the laminar and turbulent correlations.

Example:

$unitSystem SI Pa K J

T=363 [K] "average temperature of fluid in duct"

P=101300 [Pa] "pressure of air in annulus"

m_dot=0.001 [kg/s] "flow rate"

r_i=0.01 [m] "inner radius"

r_o=0.025 [m] "outer radius"

L=5 [m] "length"

RelRough=0.005 [-] "relative roughness"

call AnnularFlow('air',T,P,m_dot,r_i, r_o,L,RelRough:h_T, h_H ,DELTAP, Nusselt_T, f, Re)

{Solution:

h_T=9.295 [W/m^2-K]

h_H=11.42 [W/m^2-K]

DELTAP=3.73 [Pa]

Nusselt_T=9.225 [-]

f=0.1184 [-]}


AnnularFlow_local

Procedure AnnularFlow_local( Fluid$, T, P, m_dot, r_i, r_o, L, RelRough: h_T_x, h_H_x, dPdx) returns lower and upper bounds for the local convection coefficient and the local pressure gradient for flow in an annular duct. The local values are determined at axial position x by numerically differentiating the average values. The outer wall of the annulus is assumed to be insulated so heat transfer occurs across the wall separating the annulus from the pipe. The area used for heat transfer should be the area of this wall.

Inputs:

Fluid$ can be any fluid in the EES database. The fluid can be an ideal gas or a real fluid.

T - the bulk temperature of the fluid [C], [K], [F], or [R].

P - pressure can be in [Pa], [kPa], [bar], [MPa], [atm], or [psia].

m_dot - mass flow rate in [kg/s] or [lbm/hr]

r_i - inner radius of annulus [m] or [ft]

r_o - outer radius of annulus [m] or [ft]

x - location along the flow axis [m] or [ft]

RelRough - the ratio of the dispersions on the walls of the duct to the hydraulic diameter of the duct (must be between 0 and 0.05). The hydraulic diameter is 2 W H/(W + H).

Outputs: (all but the first output are optional)

h_T_x - lower bound on the local heat transfer coefficient in [W/m^2-K] or [Btu/hr-ft^2-R] assuming that the inner annulus wall is at constant temperature

h_H_x - upper bound on the local heat transfer coefficient in [W/m^2-K] or [Btu/hr-ft^2-R] assuming a constant heat flux at the inner annulus wall

dPdx - local pressure gradient. [(Pa, kPa, bar, or atm)/m] or [(psi or atm)/ft] depending on EES pressure unit setting

Notes:

This procedure determines the local values by differentiating the average values calculated in the AnnularFlow procedure .

Two values of the heat transfer coefficient are returned that provide upper and lower bounds. These heat transfer coefficients are both for the inner annular wall with an insulated outer wall. For turbulent flow, these values are identical.

Example:

$unitSystem SI K Pa J

T=363 [K] "average temperature of fluid in duct"

P=101300 [Pa] "pressure of air in annulus"

m_dot=0.001 [kg/s] "flow rate"

r_i=0.01 [m] "inner radius"

r_o=0.025 [m] "outer radius"

x=5 [m] "length"

RelRough=0.005 [-] "relative roughness"

call AnnularFlow_local('air', T, P, m_dot, r_i, r_o, x, RelRough:h_T_x, h_H_x, dPdx)

{Solution:

dPdx=-0.704 [Pa/m]

h_H_x=9.415 [W/m^2-K]

h_T_x=8.000 [W/m^2-K]}


AnnularFlow_N

Procedure AnnularFlow_N(Re, Pr, LoverD_h, r|star, relRough: Nusselt_T,Nusselt_H, f) returns the lower and upper bounds on the Nusselt number for fully-developed flow in an annulus characterized by inner and outer radii. The outer wall of the annulus is assumed to be insulated so heat transfer occurs across the wall separating the annulus from the pipe. The area used for heat transfer should be the area of this wall. The procedure also returns the friction factor for these conditions.

Inputs:

Re - Reynolds number based on properties evaluated at the bulk average temperature

Pr - Prandtl number of the fluid evaluated at the bulk average temperature

LoverD_h - ratio of tube length to hydraulic diameter.

r|star - ratio of the inner to the outer radius of the annulus This value should be <=1 and >0

RelRough - the ratio of the dispersions on the wall of the tube to the tube diameter (must be between 0 and 0.05)

Outputs:

Nusselt_T - lower bound on the Nusselt number assuming a constant annular wall temperature

Nusselt_H - upper bound on the Nusselt number assuming a constant annular wall heat flux

f - friction factor [-]

Notes:

This procedure is called by AnnularFlow . It calls AnnularFlow_Laminar and PipeFlow_Turbulent to obtain the appropriate Nusselt numbers and the friction factor.

The procedure will determine if the flow is laminar or turbulent. Transitional flow is assumed to occur for Reynolds numbers (based on hydraulic diameter) between 2300 and 3000 and interpolation is applied between the laminar and turbulent correlations.

The parameter LoverD_h is used to apply a developing flow correction for the turbulent flow, if necessary. Set LoverD_h to a large number if developing flow corrections are not applicable.

Two values of the Nusselt number coefficient are returned that should provide upper and lower bounds. These coefficients are both for the inner annular wall with an insulated outer wall. They both correspond to fully developed flow. For turbulent flow, these values are identical.

Example:

Re=1500

Pr=0.72

LoverD=20

r|star=0.5

relRough=0

call AnnularFlow_N(Re, Pr, LoverD, r|star, relRough: Nusselt_T,Nusselt_H, f)

{Solution:

f=0.1008 [-]

Nusselt_H=20.88

Nusselt_T=15.18 [-]}


AnnularFlow_Laminar

Procedure AnnularFlow_Laminar(Re, Pr, LoverD, r|star : Nusselt_T, Nusselt_H, f) returns lower and upper bounds on the Nusselt number and friction factor for fully-developed flow in a an annular space assuming laminar flow. The flow is characterized by Reynolds and Prandtl numbers and the ratio of the inner to outer annular radius. The Reynold's number is expected to be < 2300.

Inputs:

Re - Reynolds number based on properties evaluated at the bulk average temperature

Pr - Prandtl number of the fluid evaluated at the bulk average temperature

LoverD - length to diameter ratio

r|star - ratio of inner to outer radius

Outputs:

Nusselt_T - lower bound on the average Nusselt number (based on the annular wall surface area)

Nusselt_H - upper bound on the average Nusselt number (based on the annular wall surface area)

f - apparent Darcy friction factor [-] .

Notes:

The Darcy friction factor is calculated using a correlation recommended in Eqn 431 of Shah and London (1978) . The correlation is corrected for the developing region using the form provided by Shah and London.

The Nusselt numbers returned from this procedure apply to the wall separating the annulus from the pipe for fully-developed flow. The outer wall of the annulus is assumed to be adiabatic. Two values are provided to provide upper and lower bounds. The values are based on data in tables 89 and 90 of Shah and London (1978) .


AnnularFlow_N_local

Missing image: annularflow_n_local.gif

Procedure AnnularFlow_N_local(Re, Pr, xoverD_h, r|star, relRough: Nusselt_T_x,Nusselt_H_x, f_x) returns the lower and upper bounds on the local Nusselt number for fully-developed flow in an annulus characterized by inner and outer radii. The outer wall of the annulus is assumed to be insulated so heat transfer occurs across the wall separating the annulus from the pipe. The area used for heat transfer should be the area of this wall. The procedure also returns the local friction factor for these conditions.

Inputs:

Re - Reynolds number based on properties evaluated at the bulk average temperature

Pr - Prandtl number of the fluid evaluated at the bulk average temperature

xoverD_h - ratio of local axial position to hydraulic diameter.

r|star - ratio of the inner to the outer radius of the annulus This value should be <=1 and >0

RelRough - the ratio of the dispersions on the wall of the tube to the tube diameter (must be between 0 and 0.05)

Outputs:

Nusselt_T_x - lower bound on the local Nusselt number assuming a constant annular wall temperature

Nusselt_H - upper bound on the local Nusselt number assuming a constant annular wall heat flux

f - local friction factor [-]

Notes:

This procedure determines local values by differentiating the average values from procedure AnnularFlow_N .

Two values of the Nusselt number coefficient are returned that should provide upper and lower bounds. These coefficients are both for the inner annular wall with an insulated outer wall. They both correspond to fully developed flow. For turbulent flow, these values are identical.

Example:

Re=1500

Pr=0.72

xoverD_h=20

relRough=0

call AnnularFlow_N(Re,Pr,xoverD_h,0.35,RelRough: Nusselt_T_x, Nusselt_H_x, f_x)

{Solution:

f_x=0.1005

Nusselt_H_x=21.64 [-]

Nusselt_T_x=16 [-]}


American Standard Pipe Dimensions*

The function provides information on common pipes used in the U.S. The data are from:

http://academic.evergreen.edu/projects/biophysics/technotes/fabric/pipe.htm

Inputs:

Size is the accepted industry size specification in inches.

Schedule is an integer that can be 10, 40, 80 or 160

Outputs:

OD is the nominal outer diameter in inches

ID is the inner diameter in inches

WallThickness is the wall thickness in inches

Flow area is the internal flow area in ft^2

Example:

Size = 1 [in]

Schedule=40

call AmericanPipeDimensions(Size, Schedule: OD, ID, WallThickness, FlowArea)

{Solution:

FlowArea=0.006002 [ft^2]

ID=1.049 [in]

OD=1.315 [in]

WallThickness=0.133 [in]}


Pipe Dimensions

The PipeDimensions function provides information on the size of standard pipes including the inner diameter, the outer diameter, the wall thickness and the flow area. This function is applicable for both english and metric size pipes. The data are from:

http//en.wikipedia.org/wiki/Nominal_Pipe_Size#cite_note-table-5

and

http//www.engineersedge.com/pipe_schedules.htm

Inputs:

Size is the accepted industry size specification in inches (if the EES unit system in configured in English units) or mm (if EES is configured in SI units).

Schedule$ is an string that can be 5s, 5, 10s 10, 20, 30, 40s, 40 60, 80s, 80, 100, 120, 140, 160 or DblEH

Outputs:

OD is the nominal outer diameter in inches or mm (depending if EES is configured in English or SI units)

ID is the inner diameter in inches or mm

WallThickness is the wall thickness in inches or mm

Flow area is the internal flow area in ft^2 or m^2

Notes:

The PipeDimensions function similar to the AmericanPipeDimensions function but it provides pipe size information for a larger range of pipe sizes and types in both SI and English units. The AmericanPipeDimensions is still available for backward compatitibility.

Example:

$UnitSystem Eng

Size = 1 [in]

Schedule$='40'

call PipeDimensions(Size, Schedule$: OD, ID, WallThickness, FlowArea)

{Solution:

FlowArea=0.006002 [ft^2]

ID=1.049 [in]

OD=1.315 [in]

WallThickness=0.133 [in]}


Churchill (1977)

Churchill, S.W. 1977, 'Friction Factor Spans All Fluid Flow Regimes,' Chem. Eng. (Rugby, U.K.) 84(24), pp.91-91)


Gnielinski (1976)

Gnielinski, V., Int. Chem. Eng., Vol. 16, p. 359, 1976


Incropera and DeWitt (2002)

Incropera, F.P. and DeWitt, D.P., Introduction to Heat Transfer, 4th Ed., Wiley, 2002


Shah and London (1978)

Shah, R.K. and London, A.L. "Laminar Flow Forced Convection in Ducts", Academic Press, 1978


Hornbeck (1965)

Hornbeck, R.W. "An All-Numerical Method for Heat Transfer in the Inlet of a Tube, ASME, Paper, 65-WA/HT-36, (1965)


Petukhov (1970)

Petukhov, B.S., in Advances in Heat Transfer, Vol. 6, Irvine and Hartnett, Academic Press, 1970


Kakaç et al. (1987)

Kakaç, S, Shah, R.K, and Aung, W., "Handbook of Single-Phase Convective Heat Transfer,", Wiley-Interscience, 1987.


Schlichting (1968)

Schlichting, H. Boundary Layer Theory, 6th ed. McGraw-Hill, New York, 1968. in Incropera, F.P. and DeWitt, D.P., Introduction to Heat Transfer, 4th Ed., Wiley, 2002.


Zigrang and Sylvester (1982)

Zigrang, D.J. and N.D. Sylvester, "Explicit approximations to the solution of Colebrook's friction factor equation," AIChE Journal, Vol. 28, pp. 514-515, (1982).


Li, Seem and Li (2011)

P. Li, J.E. Seem, and Y.Li

"A New Explicit Equation for Accurate Friction Factor Calculation of Smooth Tubes"

International Journal of Refrigeration, to be published (2011)


Nellis and Klein

Heat Transfer

G.F. Nellis and S.A. Klein

Cambridge University Press, 2009