Index

Fin Efficiency Library Index

Two functions are provided for each of the following fin geometries. One function determines the fin efficiency in terms of dimensional variables such as the fin dimensions, thermal conductivity, and heat transfer coefficient. The second function accepts the non-dimensional product of the fin parameter, m, and the fin length, L. Both the dimensional and non-dimensional fin efficiency functions are described for each fin geometry. Fin efficiencies are discussed in Section 1.6.3 of Nellis and Klein .

Rectangular Base Fins

Circular Base Fins

Annular Fins


Straight-Base Rectangular Fin

Dimensional: eta_fin_straight_rect(th, L, h, k)

Function eta_fin_straight_rect calculates the fin efficiency of a straight fin with a rectangular base. This function is applicable for a fin where W>>th (i.e., the fin is infinitely long into the page). To account for the convection from the tip, the function will use a corrected length where:

The function then calls a corresponding non-dimensional function, which determines the fin efficiency in terms of the fin parameter mL, described below. Note that the fin surface area that should be used with this fin efficiency is:

Inputs:

L - length of the fin [m or ft]

th - thickness of the fin [m or ft]

h - heat transfer coefficient [W/m^2-K or Btu/hr-ft^2-R]

k - conductivity of fin material [W/m-K or Btu/hr-ft-R]

The units for the inputs to the function are based on the unit setting in EES.

Example:

$UnitSystem SI K Pa J

L=0.06 [m]

th=0.003 [m]

h=60 [W/m^2-K]

k=200 [W/m-K]

eta=eta_fin_straight_rect(th, L, h, k)

{Solution:eta=0.8063}

Non-dimensional: eta_fin_straight_rect_ND(mL)

Function eta_fin_straight_rect_ND returns the fin efficiency of a straight fin with a rectangular base given the product of the fin parameter, m, and fin length, L, where m is defined as:

Index


Straight-Base Triangular Fin

Dimensional: eta_fin_straight_triangular(th, L, h, k)

Function eta_fin_straight_triangular calculates the fin efficiency of a triangular fin with a rectangular base. The function then calls a corresponding non-dimensional function, which determines the fin efficiency. Note that the fin surface area that should be used with this fin efficiency is:

Inputs:

L - length of the fin [m or ft]

th - thickness of the fin at the base [m or ft]

h - heat transfer coefficient [W/m^2-K or Btu/hr-ft^2-R]

k - conductivity of fin material [W/m-K or Btu/hr-ft-R]

Example:

$UnitSystem SI K Pa J

L=0.06 [m]

th=0.003 [m]

h=60 [W/m^2-K]

k=200 [W/m-K]

eta=eta_fin_straight_triangular(th, L, h, k)

{Solution: eta=0.7557}

Non-dimensional: eta_fin_straight_triangular_ND(mL)

Function eta_fin_straight_triangular_ND returns the fin efficiency of a triangular fin with a rectangular base given the product of the fin parameter, m, and fin length, L, where m is defined as:


Straight-Base Concave Parabolic Fin

Dimensional: eta_fin_straight_parabolic(th, L, h, k)

Function eta_fin_straight_parabolic calculates the fin efficiency of a concave parabolic fin with a parabolic base. The function then calls a corresponding non-dimensional function, which determines the fin efficiency. Note that the fin surface area that should be used with this fin efficiency is:

Inputs:

L - length of the fin [m or ft]

th - thickness of the fin at the base [m or ft]

h - heat transfer coefficient [W/m^2-K or Btu/hr-ft^2-R]

k - conductivity of fin material [W/m-K or Btu/hr-ft-R]

Example:

$UnitSystem SI K Pa J

L=0.06 [m]

th=0.003 [m]

h=60 [W/m^2-K]

k=200 [W/m-K]

eta=eta_fin_straight_parabolic(th, L, h, k)

{Solution: eta=0.7557}

Non-dimensional: eta_fin_straight_parabolic_ND(mL)

Function eta_fin_straight_parabolic_ND returns the fin efficiency of a concave parabolic fin with a rectangular base given the product of the fin parameter, m, and fin length, L, where m is defined as:


Straight-Base Convex Parabolic Fin

Dimensional: eta_fin_straight_parabolic2(th, L, h, k)

Function eta_fin_straight_parabolic2 calculates the fin efficiency of a convex parabolic fin with a rectangular parabolic base. The function then calls a corresponding non-dimensional function, which determines the fin efficiency. Note that the fin surface area that should be used with this fin efficiency is:

Inputs:

L - length of the fin [m or ft]

th - thickness of the fin at the base [m or ft]

h - heat transfer coefficient [W/m^2-K or Btu/hr-ft^2-R]

k - conductivity of fin material [W/m-K or Btu/hr-ft-R]

Example:

$UnitSystem SI K Pa J

L=0.06 [m]

th=0.003 [m]

h=60 [W/m^2-K]

k=200 [W/m-K]

eta=eta_fin_straight_parabolic2(th, L, h, k)

{Solution: eta=0.7879}

Non-dimensional: eta_fin_straight_parabolic2_ND(mL)

Function eta_fin_straight_parabolic2_ND returns the fin efficiency of a convex parabolic fin with a rectangular base given the product of the fin parameter, m, and fin length, L, where m is defined as:


Circular-Base Rectangular Fin

Dimensional: eta_fin_spine_rect(D, L, h, k)

Function eta_fin_spine_rect calculates the fin efficiency of a rectangular fin with a circular base. To account for the convection from the tip, the function will use a corrected length where:

The function then calls a corresponding non-dimensional function, which determines the fin efficiency. Note that the fin surface area that should be used with this fin efficiency is:

Inputs:

L - length of the fin [m or ft]

D - diameter of the fin [m or ft]

h - heat transfer coefficient [W/m^2-K or Btu/hr-ft^2-R]

k - conductivity of fin material [W/m-K or Btu/hr-ft-R]

Example:

$UnitSystem SI K Pa J

L=0.075 [m]

D=0.005 [m]

h=60 [W/m^2-K]

k=200 [W/m-K]

eta=eta_fin_spine_rect(D, L, h, k)

{Solution: eta=0.7008}

Non-dimensional: eta_fin_spine_rect_ND(mL)

Function eta_fin_spine_rect_ND returns the fin efficiency of a rectangular fin with a circular base given the product of the fin parameter, m, and fin length, L, where m is defined as:


Circular-Base Triangular Fin

Dimensional: eta_fin_spine_triangular(D, L, h, k)

Function eta_fin_spine_triangular calculates the fin efficiency of a triangular fin with a circular base. The function then calls a corresponding non-dimensional function, which determines the fin efficiency. Note that the fin surface area that should be used with this fin efficiency is:

Inputs:

L - length of the fin [m or ft]

D - diameter of the fin at the base [m or ft]

h - heat transfer coefficient [W/m^2-K or Btu/hr-ft^2-R]

k - conductivity of fin material [W/m-K or Btu/hr-ft-R]

Example:

L=0.075 [m]

D=0.005 [m]

h=60 [W/m^2-K]

k=200 [W/m-K]

eta=eta_fin_spine_triangular(D, L, h, k)

{Solution: eta=0.8309}

Non-dimensional: eta_fin_spine_triangular_ND(mL)

Function eta_fin_spine_triangular_ND returns the fin efficiency of a triangular fin with a circular base given the product of the fin parameter, m, and fin length, L, where m is defined as:


Circular-Base Concave Parabolic Fin

Dimensional: eta_fin_spine_parabolic(D, L, h, k)

Function eta_fin_spine_parabolic calculates the fin efficiency of a concave parabolic fin with a circular base. The function then calls a corresponding non-dimensional function, which determines the fin efficiency. Note that the fin surface area that should be used with this fin efficiency is:

Inputs:

L - length of the fin [m or ft]

D - diameter of the fin at the base [m or ft]

h - heat transfer coefficient [W/m^2-K or Btu/hr-ft^2-R]

k - conductivity of fin material [W/m-K or Btu/hr-ft-R]

Example:

$UnitSystem SI K Pa J

L=0.075 [m]

D=0.005 [m]

h=60 [W/m^2-K]

k=200 [W/m-K]

eta=eta_fin_spine_parabolic(D, L, h, k)

{Solution: eta=0.883}

Non-dimensional: eta_fin_spine_parabolic_ND(mL)

Function eta_fin_spine_parabolic_ND returns the fin efficiency of a parabolic fin with a circular base given the product of the fin parameter, m, and fin length, L, where m is defined as:


Circular-Base Convex Parabolic Fin

Dimensional: eta_fin_spine_parabolic2(D, L, h, k)

Function eta_fin_spine_parabolic2 calculates the fin efficiency of a convex parabolic fin with a circular base. The function then calls a corresponding non-dimensional function, which determines the fin efficiency. Note that the fin surface area that should be used with this fin efficiency is:

Inputs:

L - length of the fin [m or ft]

D - diameter of the fin at the base [m or ft]

h - heat transfer coefficient [W/m^2-K or Btu/hr-ft^2-R]

k - conductivity of fin material [W/m-K or Btu/hr-ft-R]

Example:

$UnitSystem SI K Pa J

L=0.075 [m]

D=0.005 [m]

h=60 [W/m^2-K]

k=200 [W/m-K]

eta=eta_fin_spine_parabolic2(D, L, h, k)

{Solution: eta=0.6634}

Non-dimensional: eta_fin_spine_parabolic2_ND(mL)

Function eta_fin_spine_parabolic2_ND returns the fin efficiency of a convex parabolic fin with a circular base given the product of the fin parameter, m, and fin length, L, where m is defined as:


Annular Rectangular Fin

Dimensional

The function eta_fin_annular_rect calculates the fin efficiency of an annular fin. The function then calls a corresponding non-dimensional function, which determines the fin efficiency. Note that the fin surface area that should be used with this fin efficiency is:

Inputs:

r_in - inner diameter of annular disk

r_out - outer diameter of annular disk

th - thickness of annular disk

h - heat transfer coefficient

k - conductivity of fin material

Example:

$UnitSystem SI K Pa J

r_in=0.01[m]

r_out=0.03 [m]

th=0.004 [m]

h=60 [W/m^2-K]

k=200 [W/m-K]

eta=eta_fin_annular_rect(th, r_in, r_out, h, k)

{Solution: eta=0.9666}

Non-dimensional: eta_fin_annular_rect_ND(mr_out, r_in\r_out)

Function eta_fin_annular_rect_ND returns the fin efficiency of an annular fin given the product of the fin parameter, m, and out radius, r_out and the ratio of the inner to outer radii. The first parameter is defined as:


Nellis and Klein

Heat Transfer

G.F. Nellis and S.A. Klein

Cambridge University Press, 2009