<Heat Exchangers>

EES has two functions designated for analyzing basic heat exchangers and balanced flow regenerators. They represent two of the most common analysis methods: effectiveness-NTU and log mean temperature difference.

Effectiveness-NTU

Usage

Capacitance Rates

Flow Configurations

Example

Origin of the equations

Log Mean Temperature Difference

Usage

Flow Configurations

Example

Limitations

EES:

© F-Chart Software

PO Box 44042.

Madison WI, 53744 USA

http:\\fchart.com


Effectiveness-NTU

HX returns either the heat exchanger effectiveness (epsilon) given the number of transfer units (Ntu) or it returns Ntu given the effectiveness..

Usage:

The general form is either:

epsilon=HX(TypeHX$, Ntu, C_1, C_2 , Return$)

or

Ntu=HX(TypeHX$, epsilon, C_1, C_2 , Return$)

depending upon the value of the text string Return$. If Return$ is set to 'epsilon' then the HX returns the effectiveness but if Return$ is set to 'Ntu' then HX returns Ntu. Note that all strings are case-insenstive in EES.

If epsilon is known, then it is more efficient to set Return$='Ntu'. If Ntu is known, then it is more efficient to set Return$='epsilon'.

There is always a solution for epsilon given any valid Ntu but there may not be a solution for Ntu given any valid epsilon.

Flow Configurations:

The heat exchanger flow configuration is specified with the parameter TypeHX$. The following are acceptable values (case-insensitive) for TypeHX$:

'parallelflow'

'counterflow'

'crossflow_both_unmixed'

'crossflow_one_unmixed' {C_1 must be the unmixed fluid.}

'shell&tube_N' {where N is an integer between 1 and 9, specifying the number of shell pass. The number of tube passes is then, 2N, 4N, 6N, .... . }

'regenerator' {balanced flow is assumed; HX cannot solve for Ntu given epsilon for this case.}

Capacitance rates, C_1 and C_2 :

The product of the mass flow rate (e.g., kg/s or lbm/hr) and the fluid specific heat (e.g., J/kg-K or Btu/lbm-R) is the capacitance rate. The two capacitance rates are C_1 and C_2. In most cases it does not matter which fluid is C_1 or C_2. However, for a cross-flow heat exchanger with one fluid mixed, C_1 must be the unmixed fluid. If one fluid is at a constant temperature (e.g., an evaporator or condenser), that fluid capacitance rate should be set to a large number compared to the other fluid (e.g., 1000 times bigger is usually sufficient). For a regenerator, C_1 is the product of the mass flow rate and specific heat of the fluid during the hot or cold flow period. The flow is assumed to be balanced so the capacitance rates and flow duration during the hot and cold flow periods are equal. C_2 is the thermal capacity of the regenerator divided by the duration of the hot or cold flow process.

Example:

"Find the outlet temperature for the cold stream and the length of a concentric tube HX."

$UnitSystem SI C J Pa

"knowns:"

T_h_i=100 [C]

T_h_o=60 [C]

T_c_i=30 [C]

m_dot_h=0.1 [kg/s]

m_dot_c=0.1 [kg/s]

U=60 [W/m^2-K]

D=0.025 [m]

c_p_oil=1900 [J/kg-K]

c_p_water=4200 [J/kg-K]

"a) What is the heat transfer and the water outlet temperature?"

C_dot_h=m_dot_h*c_p_oil

C_dot_c=m_dot_c*c_p_water

q=C_dot_h * (T_h_i-T_h_o)

q=C_dot_c * (T_c_o-T_c_i)

"b) What is the HX length?"

C_dot_min=min(C_dot_h, C_dot_c)

TypeHX$='counterflow'

q_max=C_dot_min * (T_h_i-T_c_i)

epsilon=q/q_max

Ntu=HX(TypeHX$, epsilon, C_dot_h, C_dot_c, 'Ntu')

Ntu=(U*A)/C_dot_min

A=pi*D*L

{Solution: L=40.36 m}

Origin of the Equations:

Equations used for recuperative heat exchangers in this function are taken from Tables 8-1 of Nellis and Klein . Note that for the crossflow both fluids unmixed case, it is not possible to analytically determine NTU given epsilon. In this case, NTU is determined numerically using a Subprogram in the HX library file.

The regenerator effectiveness is determined from a lookup table as a function of the NTU and utilizilation using the tabular data presented in G. D. Dragutinovic and B. S. Baclic, Operation of Counterflow Regenerators, Computational Mechanics Publications, Billerica, 1998

Index


Log Mean Temperature Difference

LMTD_CF returns the correction factor needed to determine the log mean temperature difference (LMTD) of a heat exchanger with a flow configuration other than counterflow. LMTD_CF is 1 by definition for counterflow but it will be less than one for other flow configurations as presented in section 8.2 of Nellis and Klein .

Usage:

The general form is: F=LMTD_CF(TypeHX$,P,R)

Inputs:

,

where

Ti and To, and ti and to are the temperatures at the inlet and outlet of the two streams respectively.

TypeHX$ - specifies the heat exchanger flow configuration; applicable heat exchanger geometries are listed below

Flow Configurations:

The heat exchanger flow configuration, TypeHX$, must be set to one of the following (case-insensitive) strings:

'parallelflow'

'crossflow_both_unmixed'

'crossflow_one_unmixed'

'shell&tube_N' {where N is an integer between 1 and 9, specifying the number of shell pass. The number of tube passes is then, 2N, 4N, 6N, .... . }

Limitations:

Function LMTD_CF calls HX to determine the NTU of the heat exchanger, which is then used to determine LMTD_CF. The log mean temperature difference is valid, in general, for all values of R and from 0<P<1. However, at a particular value of R, it is possible to choose a value of P for which no value for F exists. In this case, the error shown may appear as: 'There is no solution for Ntu given epsilon = ___'.

There is no analytical solution to NTU given epsilon for the 'crossflow_both_mixed' flow configuration. In this case, a subprogram is internally called to solve for NTU in an iterative manner given the effectiveness.

Example:

$UnitSystem SI K Pa J

TypeHX$='crossflow_both_unmixed'

T_h_i=400 [K] "unmixed fluid inlet temperature"

T_h_o=330 [K] "unmixed fluid inlet temperature"

t_c_i=300 [K] "mixed fluid inlet temperature"

t_c_o=325 [K] "mixed fluid outlet temperature"

P=(t_c_o-t_c_i)/(T_h_i-t_c_i)

R=(T_h_i-T_h_o)/(t_c_o-t_c_i)

F=LMTD_CF(TypeHX$,P,R)

{Solution: F=0.9253}

Index


Nellis and Klein

Heat Transfer

G.F. Nellis and S.A. Klein

Cambridge University Press, 2009