AxialConductionHX

SUBPROGRAM AxialConductionHX provides a finite difference analysis of a counterflow heat exchanger with a consideration of axial conduction in the manner described in section 8.6.4 of Nellis and Klein .

Inputs:

C_dot_H hot-side fluid capacity rate (W/K)

C_dot_C cold-side fluid capacity rate (W/K)

NTU_H hot side NTU (ratio of hot side conductance to hot side capitance rate)

NTU_C cold side NTU (ratio of cold side conductance to cold side capitance rate)

lambda axial conduction parameter

gamma concentration parameter for node distribution (0 = uniform grid; 1 is a reasonable value)

Outputs:

eff effectiveness of the heat exchanger

eff_nac effectiveness of the heat exchanger if axial conduction is not considered

Notes:

The numerical model uses 500 nodes with an exponential spacing that concentrates nodes at the ends of the heat exchanger. The spacing is controlled by the value of input gamma. If the value of gamma is set to 0, the grid will be uniform. Increasing values of gamma providing more nodes at the ends of the heat exchanger.

C_dot_H is the product of the mass flow rate and specific heat capacity of the hot fluid. C_dot_C is defined in the same manner.

NTU_H is the ratio of the conductance (heat transfer coefficient - area product) on the hot fluid side to the hot fluid capacitance rate. NTU_C is defined in the same manner.

The units of the inputs and outputs to this Subprogram must be as indicate above, regardless of the settings in the EES unit system dialog.

Example:

$unitSystem SI J K Pa

C_dot_H=130 [W/K] "hot fluid capacitance rate"

C_dot_C=130 [W/K] "cold fluid capitance rate"

NTU_H=90 [-] "hot fluid NTU"

NTU_C=90 [-] "cold fluid NTU"

lambda=0.1 "axial conduction parameter defined in section 8.7"

gamma=2 "concentration parameter for node distribution"

Call AxialConductionHX( C_dot_h, C_dot_c, NTU_h, NTU_c, lambda,gamma: eff, eff_nac)

{Solving results in eff=0.899 and eff_nac=0.978}


Regenerator Numerical Model

RegeneratorHX

SUBPROGRAM RegeneratorHX implements a general numerical solution for a regenerator as described in section 8.10.5 of Nellis and Klein .

Inputs:

m_dot_HTCB hot-to-cold blow mass flow rate (kg/s)

T_H_in hot fluid inlet temperature (K or C)

m_dot_CTHB cold-to-hot blow mass flow rate (kg/s)

T_C_in cold fluid inlet temperature (K or C)

c_f specific heat capacity of the fluid (J/kg-K)

rho_r density of regenerator material (kg/m^3)

c_r specific heat capacity of regenerator material (J/kg-K)

t_HTCB time for hot-to-cold blow process (s)

t_CTHB time for cold-to-hot blow process (s)

h_HTCB heat xfer coefficient, hot-to-cold blow (W/m^2-K)

h_CTHB heat xfer coefficient, cold-to-hot blow (W/m^2-K)

V_r volume of regenerator material (m^3)

A_s total surface area for heat transfer (m^2)

Outputs:

Q heat transfer rate between hot and cold fluids (J/cycle)

T_H_out hot fluid outlet temperature (K or C)

T_C_out cold fluid outlet temperature (K or C)

Notes:

The numerical model uses 10 spatial nodes and 20 nodes in time for each blow process. The number of nodes can be increased by changing N and M in the EES program, if necessary.

The units of the inputs and outputs to this subprogram must be as indicate above, regardless of the settings in the EES unit system dialog.

Example:

$UnitSystem SI K Pa J

m_dot_HTCB=0.221[kg/s] " hot-to-cold blow mass flow rate"

T_H_in=450 [K] " hot fluid inlet temperature"

m_dot_CTHB=0.121 [kg/s] " cold-to-hot blow mass flow rate"

T_C_in=310 [K] " cold fluid inlet temperature"

c_f=4230 [J/kg-K] " specific heat capacity of the fluid"

rho_r=7000 [kg/m^3] " density of regenerator material"

c_r=450 [J/kg-K] " specific heat capacity of regenerator material"

t_HTCB=22 [s] " time for hot-to-cold blow process"

t_CTHB=35 [s] " time for cold-to-hot blow process"

h_HTCB=400 [W/m^2-K] " heat xfer coefficient, hot-to-cold blow"

h_CTHB=252 [W/m^2-K] " heat xfer coefficient, cold-to-hot blow"

V_r=0.045 [m^3] " volume of regenerator material"

A_s=8.2 [m^2] " total surface area for heat transfer"

call RegeneratorHX(m_dot_HTCB, T_H_in, m_dot_CTHB, T_C_in, c_f, rho_r, c_r, t_HTCB, t_CTHB, h_HTCB, h_CTHB, V_r, A_s : Q, T_H_out, T_C_out)

{Solution: Q=1.745E6 [J/cycle]

T_C_out=407.4 [K]

T_H_out=365.1 [K]}


Nellis and Klein

Heat Transfer

G.F. Nellis and S.A. Klein

Cambridge University Press, 2009