Transient Conduction

Semi-Infinite Body

These function deal with problems involving transient response of a semi-infinite medium to a specific boundary condition as described in Section 3.3.4 of Nellis and Klein .

A semi-infinite body is a solid that extends to infinity in all but one direction. It is characterized by a single identifiable surface. In practice, a solid does not need to be infinite in all directions, rather it must be sufficienly long in the directions not considered such that the other bounds play an insignificant part in determining the temperature in the considered volume.

Assumptions: The semi-infinite medium has uniform and constant properties.

Bounded 1-Dimensional Geometry

These functions deal with problems involving transient response of 1-dimensional geometries to convection boundary conditions

Bounded 1-Dimensional Geometry (non-dimensional)

These functions deal with problems involving transient response of 1-dimensional geometries to convection boundary conditions in non-dimensional coordinates.


Constant Temperature Step

The function SemiInf1(T_i,T_s,alpha,x,time) returns the temperature for a given position and time within a semi-infinite body exposed to a step change in the surface temperature using the relation provided in Table 3-2 of Nellis and Klein .

Inputs:

T_i - initial temperature of the solid [C] or [K]

T_s - surface temperature subsequent to step [C] or [K]

alpha - thermal diffusivity [m^2/s]

x - perpendicular distance from surface [m]

time - time relative to step change (step occurred at t=0) [s]

Example:

$UnitSystem SI K Pa J

T_i=378[K]

T_s=303 [K]

alpha=0.00009547 [m^2/s]

x=0.05 [m]

time=2 [s]

T=SemiInf1(T_i,T_s,alpha,x,time)

{Solution: T = T=377.2 [K]}

Index


Uniform Heat Flux

The function SemiInf2(T_i,q``_dot_s,k,alpha,x,time) returns the temperature for a given position and time within a semi-infinite body exposed to a uniform surface heat flux using the relation provided in Table 3-2 of Nellis and Klein .

Inputs:

T_i - initial temperature of the solid [C] or [K]

q``_dot_s - surface heat flux [W/m^2]

k - thermal conductivity [W/m-K]

alpha - thermal diffusivity [m^2/s]

x - perpendicular distance from surface [m]

time - time relative to flux application (flux begins at t=0) [s]

Example:

$UnitSystem SI K Pa J

T_i=378[K]

q``_dot_s=2500 [W/m^2]

alpha=0.00010 [m^2/s]

k=50 [W/m-K]

x=0.001 [m]

time=200 [s]

T=SemiInf2(T_i,q``_dot_s,k,alpha,x,time)

{Solution T=385.9 [K]}


Convection

Function SemiInf3(T_i,T_f,h,k,alpha,x,time) returns the temperature for a given position and time within a semi-infinite body with surface convection using the relation provided in Table 3-2 of Nellis and Klein .

Inputs:

T_i - initial temperature of the solid [C] or [K]

T_f - bulk fluid temperature [C] or [K]

h - convection coefficient [W/m^2-K]

alpha - thermal diffusivity [m^2/s]

x - perpendicular distance from surface [m]

time - time relative to surface exposure (surface convection begins at t=0) [s]

Example:

$UnitSystem SI K Pa J

T_i=393[K]

T_f=355 [K]

h = 50 [W/m^2-K]

alpha=0.000004029 [m^2/s]

k=10 [W/m-K]

x=0.003 [m]

time=100 [s]

T=SemiInf3(T_i,T_f,h,k,alpha,x,time)

{Solution: T=389.5 [K]}


Energy Pulse

Function SemiInf4(T_i,E``,rho,c,alpha,x,time) returns the temperature for a given position and time within a semi-infinite body exposed to an impulse of energy per unit area at the surface using the relation provided in Table 3-2 of Nellis and Klein .

Inputs:

T_i - initial temperature of the solid [C] or [K]

E`` - energy per unit area of impulse [J/m^2]

rho - density of solid [kg/m^3]

c - specific heat of solid [J/kg-K]

alpha - thermal diffusivity [m^2/s]

x - perpendicular distance from surface [m]

time - time relative to impulse (energy impulse occurs at t=0) [s]

Example:

$UnitSystem SI K Pa J

T_i=393[K]

E``=14000 [J/m^2]

rho=8891 [kg/m^3]

c=750 [J/kg-K]

alpha=0.000001[m^2/s]

x=0.0005 [m]

time=8 [s]

T=SemiInf4(T_i,E``,rho,c,alpha,x,time)

{Solution: T=393.4 [K]}


Periodic Temperature

Function SemiInf5(T_i,DeltaT,omega,alpha,x,time) returns the temperature for a given position and time within a semi-infinite body with a sinusoidally varying surface temperature using the relation provided in Table 3-2 of Nellis and Klein .

Inputs:

T_i - initial temperature of the solid [C] or [K]

DELTAT - amplitude of surface temperature variation [C] or [K]

omega - angular velocity [rad/s]. The surface temperature is T_i+DELTAT*sin(omega*time)

alpha - thermal diffusivity (m^2/s)

x - perpendicular distance from surface [m]

time - time relative to impulse (energy impulse occurs at t=0) [s]

Example:

$UnitSystem SI K Pa J

T_i=293 [K]

DELTAT=15 [K]

omega=7.272 [rad/s]

c=383 [J/kg-K]

alpha=0.00011 [m^2/s]

x=0.01 [m]

time=0.5 [s]

T=SemiInf5(T_i,DeltaT,omega,alpha,x,time)

{Solution: T=T=295.4 [K]}


Planewall_T

Function planewall_T(x, time, T_i, T_f, alpha, k, h, L) returns the temperature ([C], [K], [F], or [R]) within a bounded plane wall exposed to convection at one surface (x=L) and adiabatic at the other surface (x=0)

Inputs:

x - distance from adiabatic surface [m] or [ft]

time - time relative to beginning of convection [sec]

T_i - initial temperature of plane wall [C], [K], [F], or [R]

T_f - bulk fluid temperature [C], [K], [F], or [R]

alpha - thermal diffusivity [m^2/s] or [ft^2/hr]

k - thermal conductivity of plane wall [W/m-K] or [Btu/hr-ft-R]

h - heat transfer coefficient [W/m^2-K] or [Btu/hr-ft^2-R]

L - thickness of plane wall [m] or [ft]

Notes:

Function planewall_T determines the non-dimensional length, Biot and Fourier numbers and calls the function planewall_ND , which determines theta. Theta is then resolved by planewall_T into the temperature. A separation of variables technique is used to solve for the temperature, as explained in section 3.5.2 of Nellis and Klein .

Example:

$UnitSystem SI K Pa J

x=0.2 [m]

time=5000 [sec]

T_i=303 [K]

T_f=363 [K]

alpha=8.608e-5 [m^2/s]

k= 233 [W/m-K]

h= 50 [W/m^2-K]

L= 0.5 [m]

T=planewall_T(x, time, T_i, T_f, alpha, k, h, L)

{Solution: T=312.4 [K]}


Planewall_Q

The function planewall_Q(time, T_i, T_f, alpha, k, h, L) returns the heat transfer per unit area ([J/m^2 or Btu/ft^2]) for a bounded plane wall exposed to convection at one surface (x=L) and adiabatic at the other surface (x=0)

Inputs:

time - time relative to beginning of convection [sec]

T_i - initial temperature of plane wall [C], [K], [F], or [R]

T_f - bulk fluid temperature [C], [K], [F], or [R]

alpha - thermal diffusivity [m^2/s] or [ft^2/hr]

k - thermal conductivity of plane wall [W/m-K] or [Btu/hr-ft-R]

h - heat transfer coefficient [W/m^2-K] or [Btu/hr-ft^2-R]

L - thickness of plane wall [m] or [ft]

Notes:

Function planewall determines the Biot and Fourier numbers and calls the function planewall_Q_ND , which determines the non-dimensional heat transfer, Q_hat. Q_hat is then multiplied by the maximum heat transfer to obtain planewall_Q, as explained in section 3.5.2 of Nellis and Klein .

Example:

$UnitSystem SI K Pa J

time=5000 [sec]

T_i=303 [K]

T_f=363 [K]

alpha=8.608e-5 [m^2/s]

k= 233 [W/m-K]

h= 50 [W/m^2-K]

L= 0.5 [m]

Q=planewall_Q(time, T_i, T_f, alpha, k, h, L)

{Solution: q``=1.328E+07 [J/m^2]}


Planewall_T_ND

The function planewall_T_ND(x_bar, Fo, Bi) returns the non-dimensional temperature within a bounded plane wall with one edge exposed to convection (x=L) and the other adiabatic _x=0). The supplied values, x_bar, Fo, Bi represent the dimensionless position, Fourier number and Biot number respectively.

Inputs:

Output:

Notes:

1. Function planewall_ND is called by the function planewall to determine the non-dimensional temperature, theta.

2. The solutions provided by EES are the 1st 20 terms of the infinite series solution, as explained in section 3.5.2 of Nellis and Klein .

3. The result for Fo<0.001 is determine by interpolation of the solution at Fo=0.001 and the known value (the initial condition) at Fo = 0.

Example:

x_bar=0.7

Fo=0.6

Bi=1.5

THETA=planewall_T_ND(x_bar, Fo, Bi)

{Solution: THETA=0.4946}


Planewall_Q_ND

The function planewall_Q_ND(Fo, Bi) returns the non-dimensional heat transfer to a bounded plane wall with one edge exposed to convection (x=L) and the other adiabatic (x=0). The supplied values, Fo, Bi represent the Fourier number and Biot number respectively. The non-dimensional heat transfer is the ratio of the actual to the maximum heat transfer into the wall. A separation of variables technique is used to solve for the temperature, as explained in section 3.5.2 of Nellis and Klein .

Inputs:

Output:

Example:

$UnitSystem SI K Pa J

Fo=0.6

Bi=1.5

Q_hat=planewall_Q_ND(Fo, Bi)

Q_max=1000 [W/m^2]

Q=Q_max*Q_hat

{Solution:

Q=457.4 [W/m^2]

Q_hat=0.4574}


Cylinder_T

Function cylinder_T(r, time, T_i, T_f, alpha, k, h, r_o) returns the temperature ([C], [K], [F], or [R]) within a long right circular cylinder with the exterior walls (r=r_o) exposed to convection.

Inputs:

r - radial position [m] or [ft]

time - time relative to beginning of convection [sec]

T_i - initial temperature of cylinder [C], [K], [F], or [R]

T_f - bulk fluid temperature [C], [K], [F], or [R]

alpha - thermal diffusivity [m^2/s] or [ft^2/hr]

k - thermal conductivity of cylinder [W/m-K] or [Btu/hr-ft-R]

h - heat transfer coefficient [W/m^2-K] or [Btu/hr-ft^2-R]

r_o - outer radius of cylinder [m] or [ft]

Notes:

Function cylinder_T determines the dimensionless length, and non-dimensional Biot and Fourier numbers. It then calls the function cylinder_T_ND which determines theta as described in Section 3.5.2 of Nellis and Klein . Theta is then resolved by cylinder into the temperature.

Example:

$UnitSystem SI K Pa J

r=0.02 [m]

time=3000 [sec]

T_i=303 [K]

T_f=363 [K]

alpha=8.608e-5 [m^2/s]

k= 233 [W/m-K]

h= 45 [W/m^2-K]

r_o= 0.1 [m]

T=cylinder_T(r, time, T_i, T_f, alpha, k, h, r_o)

{Solution: T=340.7 [K]}


Cylinder_Q

Function cylinder_Q(time, T_i, T_f, alpha, k, h, r_o) returns the heat transfer per unit length [J/m or Btu/ft] for a long right circular cylinder with the exterior walls (r=r_o) exposed to convection.

Inputs:

time - time relative to beginning of convection [sec]

T_i - initial temperature of cylinder [C], [K], [F], or [R]

T_f - bulk fluid temperature [C], [K], [F], or [R]

alpha - thermal diffusivity [m^2/s] or [ft^2/hr]

k - thermal conductivity of cylinder [W/m-K] or [Btu/hr-ft-R]

h - heat transfer coefficient [W/m^2-K] or [Btu/hr-ft^2-R]

r_o - outer radius of cylinder [m] or [ft]

Notes:

Function cylinder_Q determines non-dimensional Biot and Fourier numbers and then calls the function cylinder_Q_ND , which determines the non-dimensional heat transfer, Q_hat, as explained in section 3.5.2 of Nellis and Klein.

Example:

$UnitSystem SI K Pa J

time=3000 [sec]

T_i=303 [K]

T_f=363 [K]

alpha=8.608e-5 [m^2/s]

k= 233 [W/m-K]

h= 45 [W/m^2-K]

r_o= 0.1 [m]

Q=cylinder_Q(time, T_i, T_f, alpha, k, h, r_o)

{Solution: Q=3.213E+06 [J/m]}


Cylinder_T_ND

Function cylinder_T_ND(r_bar, Fo, Bi) returns the non-dimensional temperature within a long circular cylinder with the outside edge exposed to convection (r=r_o). The supplied values, r_bar, Fo, Bi represent the dimensionless position, Fourier number and Biot number respectively.

Inputs:

Output:

Notes:

1. Function cylinder_T_ND is called by the function cylinder_T to determine the non-dimensional temperature, theta, as explained in section 3.5.2 of Nellis and Klein.

2. The solutions provided by EES are the 1st 20 terms of the infinite series solution

3. The result for Fo<0.001 is determine by interpolation of the solution at Fo=0.001 and the known value (the initial condition) at Fo = 0.

Example:

r_bar=0.3

Fo=0.23

Bi=1.02

THETA=cylinder_T_ND(r_bar, Fo, Bi)

{Solution: THETA=0.8034}


Cylinder_Q_ND

Function cylinder_Q_ND(Fo, Bi) returns the non-dimensional heat transfer within a long circular cylinder with the outside edge exposed to convection (r=r_o). The supplied values, Fo, Bi represent the Fourier number and Biot number respectively. A separation of variable technique is used as described in Section 3.5.2 of Nellis and Klein .

Inputs:

Output:

Example:

Fo=0.23

Bi=1.02

Q_hat=cylinder_Q_ND(Fo, Bi)

{Solution: Q_hat=0.319}


Sphere_T

Function sphere_T(r, time, T_i, T_f, alpha, k, h, r_o) returns the temperature ( [C], [K], [F], or [R]) within a sphere whose outer surface (r=r_o) is exposed to convection.

Inputs:

r - radial position [m] or [ft]

time - time relative to beginning of convection [sec]

T_i - initial temperature of sphere [C], [K], [F], or [R]

T_f - bulk fluid temperature [C], [K], [F], or [R]

alpha - thermal diffusivity [m^2/s] or [ft^2/hr]

k - thermal conductivity of sphere [W/m-K] or [Btu/hr-ft-R]

h - heat transfer coefficient [W/m^2-K] or [Btu/hr-ft^2-R]

r_o - outer radius of sphere [m] or [ft]

Notes:

Function sphere_T determines the dimensionless length, and non-dimensional Biot and Fourier numbers. It then calls the function sphere_T_ND , which determines theta as described in Section 3.5.2 of Nellis and Klein . Theta is then resolved by sphere into the temperature.

Example:

$UnitSystem SI K Pa J

r=0.02 [m]

time=3000 [sec]

T_i=303 [K]

T_f=363 [K]

alpha=8.608e-5 [m^2/s]

k= 233 [W/m-K]

h= 45 [W/m^2-K]

r_o= 0.1 [m]

T=sphere_T(r, time, T_i, T_f, alpha, k, h, r_o)

{Solution: T=349.4 [K]}


Sphere_Q

Function sphere_Q(time, T_i, T_f, alpha, k, h, r_o) returns the heat transfer to a sphere ([J or Btu]) whose outer surface (r=r_o) is exposed to convection.

Inputs:

time - time relative to beginning of convection [sec]

T_i - initial temperature of sphere [C], [K], [F], or [R]

T_f - bulk fluid temperature [C], [K], [F], or [R]

alpha - thermal diffusivity [m^2/s] or [ft^2/hr]

k - thermal conductivity of sphere [W/m-K] or [Btu/hr-ft-R]

h - heat transfer coefficient [W/m^2-K] or [Btu/hr-ft^2-R]

r_o - outer radius of sphere [m] or [ft]

Notes: Function sphere determines non-dimensional Biot and Fourier numbers and then calls the function sphere_Q_ND which determines Q_hat, the dimensionless heat transfer as described in Section 3.5.2 of Nellis and Klein . The actual heat transfer is the product of Q_hat and the maximum heat transfer.

Example:

$UnitSystem SI K Pa J

time=3000 [sec]

T_i=303 [K]

T_f=363 [K]

alpha=8.608e-5 [m^2/s]

k= 233 [W/m-K]

h= 45 [W/m^2-K]

r_o= 0.1 [m]

Q=sphere_Q(time, T_i, T_f, alpha, k, h, r_o)

{Solution: Q=527,204 [J]}


Sphere_T_ND

Function sphere_T_ND(r_bar, Fo, Bi) returns the non-dimensional temperature within a sphere whose outer surface (r=r_o) is exposed to convection. The supplied values, r_bar, Fo, Bi represent the dimensionless position, Fourier number and Biot number respectively.

Inputs:

Output:

Notes:

1. Function sphere_T_ND is called by the function sphere_T to determine the non-dimensional temperature, theta, as described in Section 3.5.2 of Nellis and Klein .

2. The solutions provided by EES are the 1st 20 terms of the infinite series solution

3. The result for Fo<0.001 is determine by interpolation of the solution at Fo=0.001 and the known value (the initial condition) at Fo = 0.

Example:

r_bar=0.3

Fo=0.23

Bi=1.02

THETA=sphere_T_ND(r_bar, Fo, Bi)

{Solution:THETA=0.6895}


Sphere_Q_ND

The function sphere_Q_ND(Fo, Bi) returns the non-dimensional heat transfer into a sphere whose outer surface (r=r_o) is exposed to convection. The supplied values, Fo, Bi represent Fourier number and Biot number respectively. See Section 3.5.2 of Nellis and Klein for more information.

Inputs:

Output:

Example:

r_bar=0.3

Fo=0.23

Bi=1.02

Q_hat=sphere_Q_ND(Fo, Bi)

{Solution: Q_hat=0.4466}


Nellis and Klein

Heat Transfer

G.F. Nellis and S.A. Klein

Cambridge University Press, 2009