Moment of Inertia

This help file provides specific information on the use of the Moment of Inertia library in the Mechanical Design EES functions. The library is broken into sections and solids. Click on the category to see illustrations of these geometry. Then click on the pictureto view detailed input and output information.

Sections

Solids


Sections

Index


Solids

Index


MOI_Rectangle

Rectangular Section

This procedure returns properties of a rectangular section.

Inputs

b = width [m, ft]

h =height [m, ft]

Outputs

A =area [m^2, ft^2]

I = moment of inertia [m^4, ft^4]

Z = section modulus [m^3, ft^3]

rho = radius of gyration [m, ft]

y_bar = centroidal distance [m, ft]

Example: Call MOI_rectangle(b,h: A, I, Z, rho, y_bar)

Reference: Juvinall and Marshek, 5th edition, Fundamentals of Machine Component Design, Appendix B-1a


MOI_Triangle

Triangular Section

This procedure returns properties of a triangular section.

Inputs

b = base [m, ft]

h = height [m, ft]

Outputs

A =area [m^2, ft^2]

I = moment of inertia [m^4, ft^4]

Z = section modulus [m^3, ft^3]

rho = radius of gyration [m, ft]

y_bar = centroidal distance [m, ft]

Example: Call MOI_triangle(b,h: A, I, Z, rho, y_bar)

Reference: Juvinall and Marshek, 5th edition, Fundamentals of Machine Component Design, Appendix B-1a


MOI_Trapezod

Trapezoidal Section

This procedure returns properties of a triangular section.

Inputs

aw = top width [m, ft]

bw = bottom width [m, ft]

h = height [m, ft]

Outputs

A = area [m^2, ft^2]

I = moment of inertia [m^4, ft^4]

Z = section modulus [m^3, ft^3]

rho = radius of gyration [m, ft]

y_bar = centroidal distance [m, ft]

Example: Call MOI_trapezoid(aw, bw,h: A, I, Z, rho, y_bar)

Reference: Juvinall and Marshek, 5th edition, Fundamentals of Machine Component Design, Appendix B-1a


MOI_Circle

Circular Section

This procedure returns properties of a circular section.

Inputs

d = diameter [m, ft]

Outputs

A = area [m^2, ft^2]

I = moment of inertia [m^4, ft^4]

Z = section modulus [m^3, ft^3]

J = polar moment of inertia [m^4, ft^4]

rho = radius of gyration [m, ft]

Example: Call MOI_circle(d: A, I, Z, J, rho)

Reference: Juvinall and Marshek, 5th edition, Fundamentals of Machine Component Design, Appendix B-1a


MOI_hollowcircle

Hollow Circular Section

This procedure returns properties of a hollow circular section.

Inputs

d = diameter [m, ft]

d_i = inner diameter [m, ft]

Outputs

A = area [m^2, ft^2]

I = moment of inertia [m^4, ft^4]

Z = section modulus [m^3, ft^3]

J = polar moment of inertia [m^4, ft^4]

rho = radius of gyration [m, ft]

Example: Call MOI_hollowcircle(d: A, I, Z, J, rho)

Reference: Juvinall and Marshek, 5th edition, Fundamentals of Machine Component Design, Appendix B-1a


MOI_Cylinder

Cylinder

This procedure returns mass and moments of inertia of a cylinder.

Inputs

d = diameter of cylinder [m, ft]

L = length of cylinder [m, ft]

rho = material density [kg/m^3, lbm/ft^3]

Outputs

m=mass [kg, lb_m]

I_x = moment of inertia about the x-axis

I_y= moment of inertia about the y-axis

I_z = moment of inertia about the z-axis

Example: Call MOI_cylinder(d, L, rho:m, I_x, I_y, I_z)

Reference: Juvinall and Marshek, 5th edition, Fundamentals of Machine Component Design, Appendix B-2


MOI_Disk

Disk

This procedure returns mass and moments of inertia of a disk

Inputs

d = diameter of disk [m, ft]

t = thickness of disk [m, ft]

rho = material density [kg/m^3, lbm/ft^3]

Outputs

m=mass [kg, lb_m]

I_x = moment of inertia about the x-axis

I_y= moment of inertia about the y-axis

I_z = moment of inertia about the z-axis

Example: Call MOI_disk(d, t, rho:m, I_x, I_y, I_z)

Reference: Juvinall and Marshek, 5th edition, Fundamentals of Machine Component Design, Appendix B-2


MOI_Prism

Prism

This procedure returns mass and moments of inertia of a rectangular prism'

Inputs

a =width [m, ft]

b=height [m, ft]

c= length [m, ft]

rho = material density [kg/m^3, lbm/ft^3]

Outputs

m=mass [kg, lb_m]

I_x = moment of inertia about the x-axis

I_y= moment of inertia about the y-axis

I_z = moment of inertia about the z-axis

Example: Call MOI_prism(a, b, c, rho:m, I_x, I_y, I_z)

Reference: Juvinall and Marshek, 5th edition, Fundamentals of Machine Component Design, Appendix B-2


MOI_HollowCylinder

Hollow Cylinder

This procedure returns mass and moments of inertia of a cylinder.

Inputs

d_i =inner diameter of cylinder [m, ft]

d_o=outer diameter of cylinder [m, ft]

L = length of cylinder [m, ft]

rho = material density [kg/m^3, lbm/ft^3]

Outputs

m=mass [kg, lb_m]

I_x = moment of inertia about the x-axis

I_y= moment of inertia about the y-axis

I_z = moment of inertia about the z-axis

Example: Call MOI_hollowcylinder(d_i, d_o, L, rho:m, I_x, I_y, I_z)

Reference: Juvinall and Marshek, 5th edition, Fundamentals of Machine Component Design, Appendix B-2